- simplify debian/rules and debian/install
[debian/bti.git] / debian / changelog
1 bti (021-1) UNRELEASED; urgency=low
2
3   * New upstream release, contains changes in autoconf tools:
4     - simplify debian/rules and debian/install
5     - replace xmtlo by xsltproc, docbook-xsl, docbook-xml in debian/control
6
7  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 16:37:45 +0200
8
9 bti (020-1) unstable; urgency=low
10
11   * New upstream release:
12     - remove patch getopt.patch, included upstream
13     - remove manpage for bti-shrink-urls from debian/, included upstream
14     - upstream uses autoconf, adjust debian/rules and debian/install, remove
15       debian/manpages
16
17  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
18
19 bti (017-1) unstable; urgency=low
20
21   * New upstream release.
22   * Add build-dependency on libpcre3-dev.
23   * Refresh patch manpage-debian.patch.
24   * debian/install: add new bti-shrink-urls.
25   * debian/copyright: add information about bti-shrink-urls.
26   * Create a manpage for bti-shrink-urls.
27   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
28     target which is not easier to use than the manual installation we've been
29     using).
30   * Add a new patch getopt.patch to make the new commandline options available
31     in bti.c.
32
33  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
34
35 bti (015-1) unstable; urgency=low
36
37   * New upstream release; from the RELEASE-NOTES:
38     "--action support, bti now can output data from the twitter
39     and identica servers".
40   * Add build dependency on libxml2-dev.
41   * Refresh patch manpage-debian.patch.
42   * Set Standards-Version to 3.8.1 (no changes).
43
44  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
45
46 bti (014-1) unstable; urgency=low
47
48   * New upstream release.
49
50  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
51
52 bti (013-1) unstable; urgency=low
53
54   * New upstream release.
55   * Use dh_install instead of dh_bash-completion to install the bash
56     completion snippet in order to work around a problem on the amd64 buildd
57     (closes: #513115). Drop build dependency on bash-completion.
58
59  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
60
61 bti (012-1) unstable; urgency=low
62
63   * New upstream release.
64   * Install the new bash completion script; add bash-completion to
65     Build-Depends and Suggests.
66   * Refresh patch manpage-debian.patch.
67
68  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
69
70 bti (011-1) unstable; urgency=low
71
72   * New upstream release.
73   * Add build dependency on libreadline5-dev.
74
75  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
76
77 bti (010-1) unstable; urgency=low
78
79   * New upstream release, includes a new --proxy option and honours the
80     http_proxy environment variable (closes: #511087).
81   * Refresh patch manpage-debian.patch.
82
83  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
84
85 bti (008-1) unstable; urgency=low
86
87   * New upstream release (due to december twitter server change).
88   * Update years of packaging copyright.
89
90  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
91
92 bti (007-1) unstable; urgency=low
93
94   * New upstream release.
95
96  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
97
98 bti (006-1) unstable; urgency=low
99
100   * Initial release (Closes: #503241)
101
102  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200