New upstream release
[debian/bti.git] / debian / changelog
1 bti (032-1) UNRELEASED; urgency=low
2
3   * debian/watch: use github redirector, there are no released tarballs at the
4     moment.
5   * New upstream release
6
7  -- gregor herrmann <gregoa@debian.org>  Sat, 03 Dec 2011 00:54:11 +0100
8
9 bti (031-4) unstable; urgency=low
10
11   * Build-depend on libcurl4-nss-dev instead of libcurl4-gnutls-dev; they
12     conflict with each other, and liboauth-dev now requires the former.
13     (Fixes a not-yet-detected FTBFS.)
14
15  -- gregor herrmann <gregoa@debian.org>  Sat, 26 Nov 2011 23:53:14 +0100
16
17 bti (031-3) unstable; urgency=low
18
19   * Add patch to output the correct configfile name (identi.ca/OAuth/access
20     tokens). Thanks to Vincent Lefevre for the bug report; closes: #646681.
21
22  -- gregor herrmann <gregoa@debian.org>  Sat, 05 Nov 2011 17:48:05 +0100
23
24 bti (031-2) unstable; urgency=low
25
26   * New patch debian/patches/identi.ca-oauth.patch: change identica_* OAuth
27     URI's to point to https instead of http (closes: #602507).
28   * Set Standards-Version to 3.9.2 (no changes).
29   * Improve long description.
30
31  -- gregor herrmann <gregoa@debian.org>  Tue, 25 Oct 2011 20:35:48 +0200
32
33 bti (031-1) unstable; urgency=low
34
35   * New upstream release:
36     - addresses "bti doesn't warn if the password is incorrect": check server
37       replies in non-background mode, only in non-OAuth mode
38       (partly solves #602502)
39
40  -- gregor herrmann <gregoa@debian.org>  Tue, 22 Mar 2011 17:18:10 +0100
41
42 bti (030-1) unstable; urgency=low
43
44   * New upstream release.
45   * Switch to debhelper 8.
46
47  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
48
49 bti (029-2) unstable; urgency=low
50
51   * Upload to unstable.
52
53  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
54
55 bti (029-1) experimental; urgency=low
56
57   * New upstream release: includes fixes for
58     + "the --dry-run option has no effect (tweets get posted anyway)
59        with OAuth" (closes: #608608)
60     + "--replyto doesn't work with OAuth" (closes: #608112)
61   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
62     description and add a patch to change the name in the manpage and the
63     example config; thanks to Julien Valroff for the bug report
64     (closes: #605407).
65   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
66     upstream.
67   * Refresh remaining patches.
68   * debian/copyright: update years of upstream and packaging copyright; update
69     formatting.
70   * Don't install README anymore.
71   * Upload to experimental because of the freeze.
72
73  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
74
75 bti (028-2) unstable; urgency=low
76
77   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
78     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
79     request_token URI in order to make OAuth work with identi.ca
80     (closes: #602507).
81   * Minor fixes in README.Debian.
82
83  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
84
85 bti (028-1) unstable; urgency=low
86
87   * New upstream release:
88     - support for replying to notices
89     - adds OAuth support for both twitter and identi.ca (closes: #588235)
90     - split --background from --bash, and make the latter imply the former
91   * Refresh manpage-debian.patch.
92   * Set Standards-Version to 3.9.1 (no changes).
93   * Add build dependency on liboauth-dev.
94   * debian/rules: switch order of dh arguments (preparation for dh8).
95   * debian/copyright: update years of upstream copyright.
96   * Add README.Debian about OAuth usage.
97
98  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
99
100 bti (026-1) unstable; urgency=low
101
102   * Bump build dependency on bash-completion (needed for --with
103     bash-completion in debian/rules).
104
105   * New upstream release.
106   * Refresh patch manpage-debian.patch and DEP3 patch headers.
107   * debian/copyright: refresh DEP5 header, update years of packaging
108     copyright.
109   * Set Standards-Version to 3.8.4 (no changes).
110   * Convert to source format 3.0 (quilt). Remove quilt framework.
111     Lower debhelper dependency.
112
113  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
114
115 bti (025-1) unstable; urgency=low
116
117   * New upstream release: 
118     - set default host to twitter (closes: #563098)
119     - mention correct host in prompts (closes: #563099)
120
121  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
122
123 bti (024-1) unstable; urgency=low
124
125   * New upstream release:
126     - do not display password while user types it (LP: #386525)
127     - disable echo when reading the password
128     - add laconica group support
129   * debian/control: add Homepage field and adjust long description.
130   * Use "--with bash-completion" in debian/rules to install bash-completion
131     snippet; bump build dependencies on debhelper and bash-completion in
132     debian/control.
133
134  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
135
136 bti (023-2) unstable; urgency=low
137
138   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
139     Matthias Klose for the pointer.
140   * Set Standards-Version to 3.8.3 (no changes).
141   * Add debian/README.source to document quilt usage.
142   * Simplify debian/rules, adjust versioned build dependencies on debhelper
143     and quilt in debian/control.
144   * Use dh_bash-completion for installing the completion snippet; adjust
145     debian/rules, add a versioned build dependency on bash-completion.
146
147  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
148
149 bti (023-1) unstable; urgency=low
150
151   * New upstream release, main changes:
152     - new 'verbose' mode
153     - SSL also for twitter
154   * debian/copyright: add new additional copyright holder.
155   * Refresh patch manpage-debian.patch.
156   * debian/control: mention additional actions in long description.
157
158  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
159
160 bti (022-1) unstable; urgency=low
161
162   * New upstream release, main changes:
163     - support for custim laconi.ca instances
164     - use SSL for identi.ca
165   * debian/copyright: add additional copyright holder.
166
167  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
168
169 bti (021-1) unstable; urgency=low
170
171   * New upstream release, contains changes in autoconf tools:
172     - simplify debian/rules and debian/install
173     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
174
175  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
176
177 bti (020-1) unstable; urgency=low
178
179   * New upstream release:
180     - remove patch getopt.patch, included upstream
181     - remove manpage for bti-shrink-urls from debian/, included upstream
182     - upstream uses autoconf, adjust debian/rules and debian/install, remove
183       debian/manpages
184
185  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
186
187 bti (017-1) unstable; urgency=low
188
189   * New upstream release.
190   * Add build-dependency on libpcre3-dev.
191   * Refresh patch manpage-debian.patch.
192   * debian/install: add new bti-shrink-urls.
193   * debian/copyright: add information about bti-shrink-urls.
194   * Create a manpage for bti-shrink-urls.
195   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
196     target which is not easier to use than the manual installation we've been
197     using).
198   * Add a new patch getopt.patch to make the new commandline options available
199     in bti.c.
200
201  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
202
203 bti (015-1) unstable; urgency=low
204
205   * New upstream release; from the RELEASE-NOTES:
206     "--action support, bti now can output data from the twitter
207     and identica servers".
208   * Add build dependency on libxml2-dev.
209   * Refresh patch manpage-debian.patch.
210   * Set Standards-Version to 3.8.1 (no changes).
211
212  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
213
214 bti (014-1) unstable; urgency=low
215
216   * New upstream release.
217
218  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
219
220 bti (013-1) unstable; urgency=low
221
222   * New upstream release.
223   * Use dh_install instead of dh_bash-completion to install the bash
224     completion snippet in order to work around a problem on the amd64 buildd
225     (closes: #513115). Drop build dependency on bash-completion.
226
227  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
228
229 bti (012-1) unstable; urgency=low
230
231   * New upstream release.
232   * Install the new bash completion script; add bash-completion to
233     Build-Depends and Suggests.
234   * Refresh patch manpage-debian.patch.
235
236  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
237
238 bti (011-1) unstable; urgency=low
239
240   * New upstream release.
241   * Add build dependency on libreadline5-dev.
242
243  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
244
245 bti (010-1) unstable; urgency=low
246
247   * New upstream release, includes a new --proxy option and honours the
248     http_proxy environment variable (closes: #511087).
249   * Refresh patch manpage-debian.patch.
250
251  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
252
253 bti (008-1) unstable; urgency=low
254
255   * New upstream release (due to december twitter server change).
256   * Update years of packaging copyright.
257
258  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
259
260 bti (007-1) unstable; urgency=low
261
262   * New upstream release.
263
264  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
265
266 bti (006-1) unstable; urgency=low
267
268   * Initial release (Closes: #503241)
269
270  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200