5b22a7fa3b56da94eabf729f5a79cca83646812d
[debian/bti.git] / debian / changelog
1 bti (030-1) unstable; urgency=low
2
3   * New upstream release.
4   * Switch to debhelper 8.
5
6  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
7
8 bti (029-2) unstable; urgency=low
9
10   * Upload to unstable.
11
12  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
13
14 bti (029-1) experimental; urgency=low
15
16   * New upstream release: includes fixes for
17     + "the --dry-run option has no effect (tweets get posted anyway)
18        with OAuth" (closes: #608608)
19     + "--replyto doesn't work with OAuth" (closes: #608112)
20   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
21     description and add a patch to change the name in the manpage and the
22     example config; thanks to Julien Valroff for the bug report
23     (closes: #605407).
24   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
25     upstream.
26   * Refresh remaining patches.
27   * debian/copyright: update years of upstream and packaging copyright; update
28     formatting.
29   * Don't install README anymore.
30   * Upload to experimental because of the freeze.
31
32  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
33
34 bti (028-2) unstable; urgency=low
35
36   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
37     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
38     request_token URI in order to make OAuth work with identi.ca
39     (closes: #602507).
40   * Minor fixes in README.Debian.
41
42  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
43
44 bti (028-1) unstable; urgency=low
45
46   * New upstream release:
47     - support for replying to notices
48     - adds OAuth support for both twitter and identi.ca (closes: #588235)
49     - split --background from --bash, and make the latter imply the former
50   * Refresh manpage-debian.patch.
51   * Set Standards-Version to 3.9.1 (no changes).
52   * Add build dependency on liboauth-dev.
53   * debian/rules: switch order of dh arguments (preparation for dh8).
54   * debian/copyright: update years of upstream copyright.
55   * Add README.Debian about OAuth usage.
56
57  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
58
59 bti (026-1) unstable; urgency=low
60
61   * Bump build dependency on bash-completion (needed for --with
62     bash-completion in debian/rules).
63
64   * New upstream release.
65   * Refresh patch manpage-debian.patch and DEP3 patch headers.
66   * debian/copyright: refresh DEP5 header, update years of packaging
67     copyright.
68   * Set Standards-Version to 3.8.4 (no changes).
69   * Convert to source format 3.0 (quilt). Remove quilt framework.
70     Lower debhelper dependency.
71
72  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
73
74 bti (025-1) unstable; urgency=low
75
76   * New upstream release: 
77     - set default host to twitter (closes: #563098)
78     - mention correct host in prompts (closes: #563099)
79
80  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
81
82 bti (024-1) unstable; urgency=low
83
84   * New upstream release:
85     - do not display password while user types it (LP: #386525)
86     - disable echo when reading the password
87     - add laconica group support
88   * debian/control: add Homepage field and adjust long description.
89   * Use "--with bash-completion" in debian/rules to install bash-completion
90     snippet; bump build dependencies on debhelper and bash-completion in
91     debian/control.
92
93  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
94
95 bti (023-2) unstable; urgency=low
96
97   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
98     Matthias Klose for the pointer.
99   * Set Standards-Version to 3.8.3 (no changes).
100   * Add debian/README.source to document quilt usage.
101   * Simplify debian/rules, adjust versioned build dependencies on debhelper
102     and quilt in debian/control.
103   * Use dh_bash-completion for installing the completion snippet; adjust
104     debian/rules, add a versioned build dependency on bash-completion.
105
106  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
107
108 bti (023-1) unstable; urgency=low
109
110   * New upstream release, main changes:
111     - new 'verbose' mode
112     - SSL also for twitter
113   * debian/copyright: add new additional copyright holder.
114   * Refresh patch manpage-debian.patch.
115   * debian/control: mention additional actions in long description.
116
117  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
118
119 bti (022-1) unstable; urgency=low
120
121   * New upstream release, main changes:
122     - support for custim laconi.ca instances
123     - use SSL for identi.ca
124   * debian/copyright: add additional copyright holder.
125
126  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
127
128 bti (021-1) unstable; urgency=low
129
130   * New upstream release, contains changes in autoconf tools:
131     - simplify debian/rules and debian/install
132     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
133
134  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
135
136 bti (020-1) unstable; urgency=low
137
138   * New upstream release:
139     - remove patch getopt.patch, included upstream
140     - remove manpage for bti-shrink-urls from debian/, included upstream
141     - upstream uses autoconf, adjust debian/rules and debian/install, remove
142       debian/manpages
143
144  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
145
146 bti (017-1) unstable; urgency=low
147
148   * New upstream release.
149   * Add build-dependency on libpcre3-dev.
150   * Refresh patch manpage-debian.patch.
151   * debian/install: add new bti-shrink-urls.
152   * debian/copyright: add information about bti-shrink-urls.
153   * Create a manpage for bti-shrink-urls.
154   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
155     target which is not easier to use than the manual installation we've been
156     using).
157   * Add a new patch getopt.patch to make the new commandline options available
158     in bti.c.
159
160  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
161
162 bti (015-1) unstable; urgency=low
163
164   * New upstream release; from the RELEASE-NOTES:
165     "--action support, bti now can output data from the twitter
166     and identica servers".
167   * Add build dependency on libxml2-dev.
168   * Refresh patch manpage-debian.patch.
169   * Set Standards-Version to 3.8.1 (no changes).
170
171  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
172
173 bti (014-1) unstable; urgency=low
174
175   * New upstream release.
176
177  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
178
179 bti (013-1) unstable; urgency=low
180
181   * New upstream release.
182   * Use dh_install instead of dh_bash-completion to install the bash
183     completion snippet in order to work around a problem on the amd64 buildd
184     (closes: #513115). Drop build dependency on bash-completion.
185
186  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
187
188 bti (012-1) unstable; urgency=low
189
190   * New upstream release.
191   * Install the new bash completion script; add bash-completion to
192     Build-Depends and Suggests.
193   * Refresh patch manpage-debian.patch.
194
195  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
196
197 bti (011-1) unstable; urgency=low
198
199   * New upstream release.
200   * Add build dependency on libreadline5-dev.
201
202  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
203
204 bti (010-1) unstable; urgency=low
205
206   * New upstream release, includes a new --proxy option and honours the
207     http_proxy environment variable (closes: #511087).
208   * Refresh patch manpage-debian.patch.
209
210  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
211
212 bti (008-1) unstable; urgency=low
213
214   * New upstream release (due to december twitter server change).
215   * Update years of packaging copyright.
216
217  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
218
219 bti (007-1) unstable; urgency=low
220
221   * New upstream release.
222
223  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
224
225 bti (006-1) unstable; urgency=low
226
227   * Initial release (Closes: #503241)
228
229  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200