Improve long description.
[debian/bti.git] / debian / changelog
1 bti (031-2) UNRELEASED; urgency=low
2
3   * New patch debian/patches/identi.ca-oauth.patch: change identica_* OAuth
4     URI's to point to https instead of http (closes: #602507).
5   * Set Standards-Version to 3.9.2 (no changes).
6   * Improve long description.
7
8  -- gregor herrmann <gregoa@debian.org>  Tue, 25 Oct 2011 20:27:38 +0200
9
10 bti (031-1) unstable; urgency=low
11
12   * New upstream release:
13     - addresses "bti doesn't warn if the password is incorrect": check server
14       replies in non-background mode, only in non-OAuth mode
15       (partly solves #602502)
16
17  -- gregor herrmann <gregoa@debian.org>  Tue, 22 Mar 2011 17:18:10 +0100
18
19 bti (030-1) unstable; urgency=low
20
21   * New upstream release.
22   * Switch to debhelper 8.
23
24  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
25
26 bti (029-2) unstable; urgency=low
27
28   * Upload to unstable.
29
30  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
31
32 bti (029-1) experimental; urgency=low
33
34   * New upstream release: includes fixes for
35     + "the --dry-run option has no effect (tweets get posted anyway)
36        with OAuth" (closes: #608608)
37     + "--replyto doesn't work with OAuth" (closes: #608112)
38   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
39     description and add a patch to change the name in the manpage and the
40     example config; thanks to Julien Valroff for the bug report
41     (closes: #605407).
42   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
43     upstream.
44   * Refresh remaining patches.
45   * debian/copyright: update years of upstream and packaging copyright; update
46     formatting.
47   * Don't install README anymore.
48   * Upload to experimental because of the freeze.
49
50  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
51
52 bti (028-2) unstable; urgency=low
53
54   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
55     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
56     request_token URI in order to make OAuth work with identi.ca
57     (closes: #602507).
58   * Minor fixes in README.Debian.
59
60  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
61
62 bti (028-1) unstable; urgency=low
63
64   * New upstream release:
65     - support for replying to notices
66     - adds OAuth support for both twitter and identi.ca (closes: #588235)
67     - split --background from --bash, and make the latter imply the former
68   * Refresh manpage-debian.patch.
69   * Set Standards-Version to 3.9.1 (no changes).
70   * Add build dependency on liboauth-dev.
71   * debian/rules: switch order of dh arguments (preparation for dh8).
72   * debian/copyright: update years of upstream copyright.
73   * Add README.Debian about OAuth usage.
74
75  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
76
77 bti (026-1) unstable; urgency=low
78
79   * Bump build dependency on bash-completion (needed for --with
80     bash-completion in debian/rules).
81
82   * New upstream release.
83   * Refresh patch manpage-debian.patch and DEP3 patch headers.
84   * debian/copyright: refresh DEP5 header, update years of packaging
85     copyright.
86   * Set Standards-Version to 3.8.4 (no changes).
87   * Convert to source format 3.0 (quilt). Remove quilt framework.
88     Lower debhelper dependency.
89
90  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
91
92 bti (025-1) unstable; urgency=low
93
94   * New upstream release: 
95     - set default host to twitter (closes: #563098)
96     - mention correct host in prompts (closes: #563099)
97
98  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
99
100 bti (024-1) unstable; urgency=low
101
102   * New upstream release:
103     - do not display password while user types it (LP: #386525)
104     - disable echo when reading the password
105     - add laconica group support
106   * debian/control: add Homepage field and adjust long description.
107   * Use "--with bash-completion" in debian/rules to install bash-completion
108     snippet; bump build dependencies on debhelper and bash-completion in
109     debian/control.
110
111  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
112
113 bti (023-2) unstable; urgency=low
114
115   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
116     Matthias Klose for the pointer.
117   * Set Standards-Version to 3.8.3 (no changes).
118   * Add debian/README.source to document quilt usage.
119   * Simplify debian/rules, adjust versioned build dependencies on debhelper
120     and quilt in debian/control.
121   * Use dh_bash-completion for installing the completion snippet; adjust
122     debian/rules, add a versioned build dependency on bash-completion.
123
124  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
125
126 bti (023-1) unstable; urgency=low
127
128   * New upstream release, main changes:
129     - new 'verbose' mode
130     - SSL also for twitter
131   * debian/copyright: add new additional copyright holder.
132   * Refresh patch manpage-debian.patch.
133   * debian/control: mention additional actions in long description.
134
135  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
136
137 bti (022-1) unstable; urgency=low
138
139   * New upstream release, main changes:
140     - support for custim laconi.ca instances
141     - use SSL for identi.ca
142   * debian/copyright: add additional copyright holder.
143
144  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
145
146 bti (021-1) unstable; urgency=low
147
148   * New upstream release, contains changes in autoconf tools:
149     - simplify debian/rules and debian/install
150     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
151
152  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
153
154 bti (020-1) unstable; urgency=low
155
156   * New upstream release:
157     - remove patch getopt.patch, included upstream
158     - remove manpage for bti-shrink-urls from debian/, included upstream
159     - upstream uses autoconf, adjust debian/rules and debian/install, remove
160       debian/manpages
161
162  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
163
164 bti (017-1) unstable; urgency=low
165
166   * New upstream release.
167   * Add build-dependency on libpcre3-dev.
168   * Refresh patch manpage-debian.patch.
169   * debian/install: add new bti-shrink-urls.
170   * debian/copyright: add information about bti-shrink-urls.
171   * Create a manpage for bti-shrink-urls.
172   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
173     target which is not easier to use than the manual installation we've been
174     using).
175   * Add a new patch getopt.patch to make the new commandline options available
176     in bti.c.
177
178  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
179
180 bti (015-1) unstable; urgency=low
181
182   * New upstream release; from the RELEASE-NOTES:
183     "--action support, bti now can output data from the twitter
184     and identica servers".
185   * Add build dependency on libxml2-dev.
186   * Refresh patch manpage-debian.patch.
187   * Set Standards-Version to 3.8.1 (no changes).
188
189  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
190
191 bti (014-1) unstable; urgency=low
192
193   * New upstream release.
194
195  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
196
197 bti (013-1) unstable; urgency=low
198
199   * New upstream release.
200   * Use dh_install instead of dh_bash-completion to install the bash
201     completion snippet in order to work around a problem on the amd64 buildd
202     (closes: #513115). Drop build dependency on bash-completion.
203
204  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
205
206 bti (012-1) unstable; urgency=low
207
208   * New upstream release.
209   * Install the new bash completion script; add bash-completion to
210     Build-Depends and Suggests.
211   * Refresh patch manpage-debian.patch.
212
213  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
214
215 bti (011-1) unstable; urgency=low
216
217   * New upstream release.
218   * Add build dependency on libreadline5-dev.
219
220  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
221
222 bti (010-1) unstable; urgency=low
223
224   * New upstream release, includes a new --proxy option and honours the
225     http_proxy environment variable (closes: #511087).
226   * Refresh patch manpage-debian.patch.
227
228  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
229
230 bti (008-1) unstable; urgency=low
231
232   * New upstream release (due to december twitter server change).
233   * Update years of packaging copyright.
234
235  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
236
237 bti (007-1) unstable; urgency=low
238
239   * New upstream release.
240
241  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
242
243 bti (006-1) unstable; urgency=low
244
245   * Initial release (Closes: #503241)
246
247  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200