releasing version 029-1
[debian/bti.git] / debian / changelog
1 bti (029-1) experimental; urgency=low
2
3   * New upstream release: includes fixes for
4     + "the --dry-run option has no effect (tweets get posted anyway)
5        with OAuth" (closes: #608608)
6     + "--replyto doesn't work with OAuth" (closes: #608112)
7   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
8     description and add a patch to change the name in the manpage and the
9     example config; thanks to Julien Valroff for the bug report
10     (closes: #605407).
11   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
12     upstream.
13   * Refresh remaining patches.
14   * debian/copyright: update years of upstream and packaging copyright; update
15     formatting.
16   * Don't install README anymore.
17   * Upload to experimental because of the freeze.
18
19  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
20
21 bti (028-2) unstable; urgency=low
22
23   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
24     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
25     request_token URI in order to make OAuth work with identi.ca
26     (closes: #602507).
27   * Minor fixes in README.Debian.
28
29  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
30
31 bti (028-1) unstable; urgency=low
32
33   * New upstream release:
34     - support for replying to notices
35     - adds OAuth support for both twitter and identi.ca (closes: #588235)
36     - split --background from --bash, and make the latter imply the former
37   * Refresh manpage-debian.patch.
38   * Set Standards-Version to 3.9.1 (no changes).
39   * Add build dependency on liboauth-dev.
40   * debian/rules: switch order of dh arguments (preparation for dh8).
41   * debian/copyright: update years of upstream copyright.
42   * Add README.Debian about OAuth usage.
43
44  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
45
46 bti (026-1) unstable; urgency=low
47
48   * Bump build dependency on bash-completion (needed for --with
49     bash-completion in debian/rules).
50
51   * New upstream release.
52   * Refresh patch manpage-debian.patch and DEP3 patch headers.
53   * debian/copyright: refresh DEP5 header, update years of packaging
54     copyright.
55   * Set Standards-Version to 3.8.4 (no changes).
56   * Convert to source format 3.0 (quilt). Remove quilt framework.
57     Lower debhelper dependency.
58
59  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
60
61 bti (025-1) unstable; urgency=low
62
63   * New upstream release: 
64     - set default host to twitter (closes: #563098)
65     - mention correct host in prompts (closes: #563099)
66
67  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
68
69 bti (024-1) unstable; urgency=low
70
71   * New upstream release:
72     - do not display password while user types it (LP: #386525)
73     - disable echo when reading the password
74     - add laconica group support
75   * debian/control: add Homepage field and adjust long description.
76   * Use "--with bash-completion" in debian/rules to install bash-completion
77     snippet; bump build dependencies on debhelper and bash-completion in
78     debian/control.
79
80  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
81
82 bti (023-2) unstable; urgency=low
83
84   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
85     Matthias Klose for the pointer.
86   * Set Standards-Version to 3.8.3 (no changes).
87   * Add debian/README.source to document quilt usage.
88   * Simplify debian/rules, adjust versioned build dependencies on debhelper
89     and quilt in debian/control.
90   * Use dh_bash-completion for installing the completion snippet; adjust
91     debian/rules, add a versioned build dependency on bash-completion.
92
93  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
94
95 bti (023-1) unstable; urgency=low
96
97   * New upstream release, main changes:
98     - new 'verbose' mode
99     - SSL also for twitter
100   * debian/copyright: add new additional copyright holder.
101   * Refresh patch manpage-debian.patch.
102   * debian/control: mention additional actions in long description.
103
104  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
105
106 bti (022-1) unstable; urgency=low
107
108   * New upstream release, main changes:
109     - support for custim laconi.ca instances
110     - use SSL for identi.ca
111   * debian/copyright: add additional copyright holder.
112
113  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
114
115 bti (021-1) unstable; urgency=low
116
117   * New upstream release, contains changes in autoconf tools:
118     - simplify debian/rules and debian/install
119     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
120
121  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
122
123 bti (020-1) unstable; urgency=low
124
125   * New upstream release:
126     - remove patch getopt.patch, included upstream
127     - remove manpage for bti-shrink-urls from debian/, included upstream
128     - upstream uses autoconf, adjust debian/rules and debian/install, remove
129       debian/manpages
130
131  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
132
133 bti (017-1) unstable; urgency=low
134
135   * New upstream release.
136   * Add build-dependency on libpcre3-dev.
137   * Refresh patch manpage-debian.patch.
138   * debian/install: add new bti-shrink-urls.
139   * debian/copyright: add information about bti-shrink-urls.
140   * Create a manpage for bti-shrink-urls.
141   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
142     target which is not easier to use than the manual installation we've been
143     using).
144   * Add a new patch getopt.patch to make the new commandline options available
145     in bti.c.
146
147  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
148
149 bti (015-1) unstable; urgency=low
150
151   * New upstream release; from the RELEASE-NOTES:
152     "--action support, bti now can output data from the twitter
153     and identica servers".
154   * Add build dependency on libxml2-dev.
155   * Refresh patch manpage-debian.patch.
156   * Set Standards-Version to 3.8.1 (no changes).
157
158  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
159
160 bti (014-1) unstable; urgency=low
161
162   * New upstream release.
163
164  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
165
166 bti (013-1) unstable; urgency=low
167
168   * New upstream release.
169   * Use dh_install instead of dh_bash-completion to install the bash
170     completion snippet in order to work around a problem on the amd64 buildd
171     (closes: #513115). Drop build dependency on bash-completion.
172
173  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
174
175 bti (012-1) unstable; urgency=low
176
177   * New upstream release.
178   * Install the new bash completion script; add bash-completion to
179     Build-Depends and Suggests.
180   * Refresh patch manpage-debian.patch.
181
182  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
183
184 bti (011-1) unstable; urgency=low
185
186   * New upstream release.
187   * Add build dependency on libreadline5-dev.
188
189  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
190
191 bti (010-1) unstable; urgency=low
192
193   * New upstream release, includes a new --proxy option and honours the
194     http_proxy environment variable (closes: #511087).
195   * Refresh patch manpage-debian.patch.
196
197  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
198
199 bti (008-1) unstable; urgency=low
200
201   * New upstream release (due to december twitter server change).
202   * Update years of packaging copyright.
203
204  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
205
206 bti (007-1) unstable; urgency=low
207
208   * New upstream release.
209
210  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
211
212 bti (006-1) unstable; urgency=low
213
214   * Initial release (Closes: #503241)
215
216  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200