Build-depend on libcurl4-nss-dev instead of libcurl4-gnutls-dev; they
[debian/bti.git] / debian / changelog
1 bti (031-4) UNRELEASED; urgency=low
2
3   * Build-depend on libcurl4-nss-dev instead of libcurl4-gnutls-dev; they
4     conflict with each other, and liboauth-dev now requires the former.
5     (Fixes a not-yet-detected FTBFS.)
6
7  -- gregor herrmann <gregoa@debian.org>  Sat, 26 Nov 2011 23:44:09 +0100
8
9 bti (031-3) unstable; urgency=low
10
11   * Add patch to output the correct configfile name (identi.ca/OAuth/access
12     tokens). Thanks to Vincent Lefevre for the bug report; closes: #646681.
13
14  -- gregor herrmann <gregoa@debian.org>  Sat, 05 Nov 2011 17:48:05 +0100
15
16 bti (031-2) unstable; urgency=low
17
18   * New patch debian/patches/identi.ca-oauth.patch: change identica_* OAuth
19     URI's to point to https instead of http (closes: #602507).
20   * Set Standards-Version to 3.9.2 (no changes).
21   * Improve long description.
22
23  -- gregor herrmann <gregoa@debian.org>  Tue, 25 Oct 2011 20:35:48 +0200
24
25 bti (031-1) unstable; urgency=low
26
27   * New upstream release:
28     - addresses "bti doesn't warn if the password is incorrect": check server
29       replies in non-background mode, only in non-OAuth mode
30       (partly solves #602502)
31
32  -- gregor herrmann <gregoa@debian.org>  Tue, 22 Mar 2011 17:18:10 +0100
33
34 bti (030-1) unstable; urgency=low
35
36   * New upstream release.
37   * Switch to debhelper 8.
38
39  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
40
41 bti (029-2) unstable; urgency=low
42
43   * Upload to unstable.
44
45  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
46
47 bti (029-1) experimental; urgency=low
48
49   * New upstream release: includes fixes for
50     + "the --dry-run option has no effect (tweets get posted anyway)
51        with OAuth" (closes: #608608)
52     + "--replyto doesn't work with OAuth" (closes: #608112)
53   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
54     description and add a patch to change the name in the manpage and the
55     example config; thanks to Julien Valroff for the bug report
56     (closes: #605407).
57   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
58     upstream.
59   * Refresh remaining patches.
60   * debian/copyright: update years of upstream and packaging copyright; update
61     formatting.
62   * Don't install README anymore.
63   * Upload to experimental because of the freeze.
64
65  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
66
67 bti (028-2) unstable; urgency=low
68
69   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
70     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
71     request_token URI in order to make OAuth work with identi.ca
72     (closes: #602507).
73   * Minor fixes in README.Debian.
74
75  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
76
77 bti (028-1) unstable; urgency=low
78
79   * New upstream release:
80     - support for replying to notices
81     - adds OAuth support for both twitter and identi.ca (closes: #588235)
82     - split --background from --bash, and make the latter imply the former
83   * Refresh manpage-debian.patch.
84   * Set Standards-Version to 3.9.1 (no changes).
85   * Add build dependency on liboauth-dev.
86   * debian/rules: switch order of dh arguments (preparation for dh8).
87   * debian/copyright: update years of upstream copyright.
88   * Add README.Debian about OAuth usage.
89
90  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
91
92 bti (026-1) unstable; urgency=low
93
94   * Bump build dependency on bash-completion (needed for --with
95     bash-completion in debian/rules).
96
97   * New upstream release.
98   * Refresh patch manpage-debian.patch and DEP3 patch headers.
99   * debian/copyright: refresh DEP5 header, update years of packaging
100     copyright.
101   * Set Standards-Version to 3.8.4 (no changes).
102   * Convert to source format 3.0 (quilt). Remove quilt framework.
103     Lower debhelper dependency.
104
105  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
106
107 bti (025-1) unstable; urgency=low
108
109   * New upstream release: 
110     - set default host to twitter (closes: #563098)
111     - mention correct host in prompts (closes: #563099)
112
113  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
114
115 bti (024-1) unstable; urgency=low
116
117   * New upstream release:
118     - do not display password while user types it (LP: #386525)
119     - disable echo when reading the password
120     - add laconica group support
121   * debian/control: add Homepage field and adjust long description.
122   * Use "--with bash-completion" in debian/rules to install bash-completion
123     snippet; bump build dependencies on debhelper and bash-completion in
124     debian/control.
125
126  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
127
128 bti (023-2) unstable; urgency=low
129
130   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
131     Matthias Klose for the pointer.
132   * Set Standards-Version to 3.8.3 (no changes).
133   * Add debian/README.source to document quilt usage.
134   * Simplify debian/rules, adjust versioned build dependencies on debhelper
135     and quilt in debian/control.
136   * Use dh_bash-completion for installing the completion snippet; adjust
137     debian/rules, add a versioned build dependency on bash-completion.
138
139  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
140
141 bti (023-1) unstable; urgency=low
142
143   * New upstream release, main changes:
144     - new 'verbose' mode
145     - SSL also for twitter
146   * debian/copyright: add new additional copyright holder.
147   * Refresh patch manpage-debian.patch.
148   * debian/control: mention additional actions in long description.
149
150  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
151
152 bti (022-1) unstable; urgency=low
153
154   * New upstream release, main changes:
155     - support for custim laconi.ca instances
156     - use SSL for identi.ca
157   * debian/copyright: add additional copyright holder.
158
159  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
160
161 bti (021-1) unstable; urgency=low
162
163   * New upstream release, contains changes in autoconf tools:
164     - simplify debian/rules and debian/install
165     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
166
167  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
168
169 bti (020-1) unstable; urgency=low
170
171   * New upstream release:
172     - remove patch getopt.patch, included upstream
173     - remove manpage for bti-shrink-urls from debian/, included upstream
174     - upstream uses autoconf, adjust debian/rules and debian/install, remove
175       debian/manpages
176
177  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
178
179 bti (017-1) unstable; urgency=low
180
181   * New upstream release.
182   * Add build-dependency on libpcre3-dev.
183   * Refresh patch manpage-debian.patch.
184   * debian/install: add new bti-shrink-urls.
185   * debian/copyright: add information about bti-shrink-urls.
186   * Create a manpage for bti-shrink-urls.
187   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
188     target which is not easier to use than the manual installation we've been
189     using).
190   * Add a new patch getopt.patch to make the new commandline options available
191     in bti.c.
192
193  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
194
195 bti (015-1) unstable; urgency=low
196
197   * New upstream release; from the RELEASE-NOTES:
198     "--action support, bti now can output data from the twitter
199     and identica servers".
200   * Add build dependency on libxml2-dev.
201   * Refresh patch manpage-debian.patch.
202   * Set Standards-Version to 3.8.1 (no changes).
203
204  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
205
206 bti (014-1) unstable; urgency=low
207
208   * New upstream release.
209
210  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
211
212 bti (013-1) unstable; urgency=low
213
214   * New upstream release.
215   * Use dh_install instead of dh_bash-completion to install the bash
216     completion snippet in order to work around a problem on the amd64 buildd
217     (closes: #513115). Drop build dependency on bash-completion.
218
219  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
220
221 bti (012-1) unstable; urgency=low
222
223   * New upstream release.
224   * Install the new bash completion script; add bash-completion to
225     Build-Depends and Suggests.
226   * Refresh patch manpage-debian.patch.
227
228  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
229
230 bti (011-1) unstable; urgency=low
231
232   * New upstream release.
233   * Add build dependency on libreadline5-dev.
234
235  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
236
237 bti (010-1) unstable; urgency=low
238
239   * New upstream release, includes a new --proxy option and honours the
240     http_proxy environment variable (closes: #511087).
241   * Refresh patch manpage-debian.patch.
242
243  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
244
245 bti (008-1) unstable; urgency=low
246
247   * New upstream release (due to december twitter server change).
248   * Update years of packaging copyright.
249
250  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
251
252 bti (007-1) unstable; urgency=low
253
254   * New upstream release.
255
256  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
257
258 bti (006-1) unstable; urgency=low
259
260   * Initial release (Closes: #503241)
261
262  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200