f25b1880c62cf2eb5fee39600a8649b3398f4517
[debian/bti.git] / debian / changelog
1 bti (028-2) unstable; urgency=low
2
3   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
4     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
5     request_token URI in order to make OAuth work with identi.ca
6     (closes: #602507).
7   * Minor fixes in README.Debian.
8
9  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
10
11 bti (028-1) unstable; urgency=low
12
13   * New upstream release:
14     - support for replying to notices
15     - adds OAuth support for both twitter and identi.ca (closes: #588235)
16     - split --background from --bash, and make the latter imply the former
17   * Refresh manpage-debian.patch.
18   * Set Standards-Version to 3.9.1 (no changes).
19   * Add build dependency on liboauth-dev.
20   * debian/rules: switch order of dh arguments (preparation for dh8).
21   * debian/copyright: update years of upstream copyright.
22   * Add README.Debian about OAuth usage.
23
24  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
25
26 bti (026-1) unstable; urgency=low
27
28   * Bump build dependency on bash-completion (needed for --with
29     bash-completion in debian/rules).
30
31   * New upstream release.
32   * Refresh patch manpage-debian.patch and DEP3 patch headers.
33   * debian/copyright: refresh DEP5 header, update years of packaging
34     copyright.
35   * Set Standards-Version to 3.8.4 (no changes).
36   * Convert to source format 3.0 (quilt). Remove quilt framework.
37     Lower debhelper dependency.
38
39  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
40
41 bti (025-1) unstable; urgency=low
42
43   * New upstream release: 
44     - set default host to twitter (closes: #563098)
45     - mention correct host in prompts (closes: #563099)
46
47  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
48
49 bti (024-1) unstable; urgency=low
50
51   * New upstream release:
52     - do not display password while user types it (LP: #386525)
53     - disable echo when reading the password
54     - add laconica group support
55   * debian/control: add Homepage field and adjust long description.
56   * Use "--with bash-completion" in debian/rules to install bash-completion
57     snippet; bump build dependencies on debhelper and bash-completion in
58     debian/control.
59
60  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
61
62 bti (023-2) unstable; urgency=low
63
64   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
65     Matthias Klose for the pointer.
66   * Set Standards-Version to 3.8.3 (no changes).
67   * Add debian/README.source to document quilt usage.
68   * Simplify debian/rules, adjust versioned build dependencies on debhelper
69     and quilt in debian/control.
70   * Use dh_bash-completion for installing the completion snippet; adjust
71     debian/rules, add a versioned build dependency on bash-completion.
72
73  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
74
75 bti (023-1) unstable; urgency=low
76
77   * New upstream release, main changes:
78     - new 'verbose' mode
79     - SSL also for twitter
80   * debian/copyright: add new additional copyright holder.
81   * Refresh patch manpage-debian.patch.
82   * debian/control: mention additional actions in long description.
83
84  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
85
86 bti (022-1) unstable; urgency=low
87
88   * New upstream release, main changes:
89     - support for custim laconi.ca instances
90     - use SSL for identi.ca
91   * debian/copyright: add additional copyright holder.
92
93  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
94
95 bti (021-1) unstable; urgency=low
96
97   * New upstream release, contains changes in autoconf tools:
98     - simplify debian/rules and debian/install
99     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
100
101  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
102
103 bti (020-1) unstable; urgency=low
104
105   * New upstream release:
106     - remove patch getopt.patch, included upstream
107     - remove manpage for bti-shrink-urls from debian/, included upstream
108     - upstream uses autoconf, adjust debian/rules and debian/install, remove
109       debian/manpages
110
111  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
112
113 bti (017-1) unstable; urgency=low
114
115   * New upstream release.
116   * Add build-dependency on libpcre3-dev.
117   * Refresh patch manpage-debian.patch.
118   * debian/install: add new bti-shrink-urls.
119   * debian/copyright: add information about bti-shrink-urls.
120   * Create a manpage for bti-shrink-urls.
121   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
122     target which is not easier to use than the manual installation we've been
123     using).
124   * Add a new patch getopt.patch to make the new commandline options available
125     in bti.c.
126
127  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
128
129 bti (015-1) unstable; urgency=low
130
131   * New upstream release; from the RELEASE-NOTES:
132     "--action support, bti now can output data from the twitter
133     and identica servers".
134   * Add build dependency on libxml2-dev.
135   * Refresh patch manpage-debian.patch.
136   * Set Standards-Version to 3.8.1 (no changes).
137
138  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
139
140 bti (014-1) unstable; urgency=low
141
142   * New upstream release.
143
144  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
145
146 bti (013-1) unstable; urgency=low
147
148   * New upstream release.
149   * Use dh_install instead of dh_bash-completion to install the bash
150     completion snippet in order to work around a problem on the amd64 buildd
151     (closes: #513115). Drop build dependency on bash-completion.
152
153  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
154
155 bti (012-1) unstable; urgency=low
156
157   * New upstream release.
158   * Install the new bash completion script; add bash-completion to
159     Build-Depends and Suggests.
160   * Refresh patch manpage-debian.patch.
161
162  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
163
164 bti (011-1) unstable; urgency=low
165
166   * New upstream release.
167   * Add build dependency on libreadline5-dev.
168
169  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
170
171 bti (010-1) unstable; urgency=low
172
173   * New upstream release, includes a new --proxy option and honours the
174     http_proxy environment variable (closes: #511087).
175   * Refresh patch manpage-debian.patch.
176
177  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
178
179 bti (008-1) unstable; urgency=low
180
181   * New upstream release (due to december twitter server change).
182   * Update years of packaging copyright.
183
184  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
185
186 bti (007-1) unstable; urgency=low
187
188   * New upstream release.
189
190  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
191
192 bti (006-1) unstable; urgency=low
193
194   * Initial release (Closes: #503241)
195
196  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200