depend on default-jre (at least Java 6)
authortony mancill <tmancill@debian.org>
Wed, 15 Oct 2014 03:48:36 +0000 (20:48 -0700)
committertony mancill <tmancill@debian.org>
Wed, 15 Oct 2014 03:48:36 +0000 (20:48 -0700)
This doesn't really address #711842, but it will prevent the
installation of openjdk-7 when openjdk-8 becomes the default.

debian/control

index 0bae8ae..09e71e2 100644 (file)
@@ -51,7 +51,7 @@ Depends: ${misc:Depends},
          libpdfbox-java (>= 1:1.5.0),
          libpostgresql-jdbc-java,
          libspin-java,
-         openjdk-7-jre | java6-runtime,
+         default-jre (>=2:1.6) | java6-runtime,
          velocity
 Recommends: xdg-utils,
             libreoffice-java-common,