Fixed: Forgot to call query.exec() at several places.
[toast/confclerk.git] / confclerk.pro
index 8f2160c..0b8db1a 100644 (file)
@@ -3,16 +3,16 @@
 QMAKEVERSION = $$[QMAKE_VERSION]
 ISQT4 = $$find(QMAKEVERSION, ^[2-9])
 isEmpty( ISQT4 ) {
-error("Use the qmake include with Qt4.4 or greater, on Debian that is
-qmake-qt4");
+       error("Use the qmake include with Qt4.4 or greater, on Debian that is qmake-qt4");
 }
 
 TEMPLATE = subdirs
 SUBDIRS = src
 
-VERSION = 0.5.0
+# The global.pri defines the VERSION of the project
+include(src/global.pri)
+
 
-QMAKE_DISTCLEAN += src/bin/*.a
 QMAKE_EXTRA_TARGETS += changelog icon man release tarball
 
 changelog.target = ChangeLog
@@ -35,10 +35,10 @@ tarball.commands = \
        $(DEL_FILE) -r $${TARGET}-$${VERSION} ; \
        $(MKDIR) $${TARGET}-$${VERSION} ; \
        $(COPY_DIR) * $${TARGET}-$${VERSION}/ ; \
-       $(DEL_FILE) $${TARGET}-$${VERSION}/*.pro.user \
+       $(DEL_FILE) $${TARGET}-$${VERSION}/*.pro.user* \
                $${TARGET}-$${VERSION}/$${TARGET}-$${VERSION}.tar.gz \
                $(DEL_FILE) -r $${TARGET}-$${VERSION}/$${TARGET}-$${VERSION} \
                $${TARGET}-$${VERSION}/Makefile ; \
-       tar -cz --exclude=.svn -f $$tarball.target $${TARGET}-$${VERSION} ; \
+       tar -cz --exclude=.svn --exclude=*.tar.gz -f $$tarball.target $${TARGET}-$${VERSION} ; \
        $(DEL_FILE) -r $${TARGET}-$${VERSION}
-tarball.depends = changelog icon man distclean
+tarball.depends = changelog icon man