80f844837f7c7b60989819f88a398e9025679907
[debian/bti.git] / debian / changelog
1 bti (028-1) unstable; urgency=low
2
3   * New upstream release:
4     - support for replying to notices
5     - adds OAuth support for both twitter and identi.ca (closes: #588235)
6     - split --background from --bash, and make the latter imply the former
7   * Refresh manpage-debian.patch.
8   * Set Standards-Version to 3.9.1 (no changes).
9   * Add build dependency on liboauth-dev.
10   * debian/rules: switch order of dh arguments (preparation for dh8).
11   * debian/copyright: update years of upstream copyright.
12   * Add README.Debian about OAuth usage.
13
14  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
15
16 bti (026-1) unstable; urgency=low
17
18   * Bump build dependency on bash-completion (needed for --with
19     bash-completion in debian/rules).
20
21   * New upstream release.
22   * Refresh patch manpage-debian.patch and DEP3 patch headers.
23   * debian/copyright: refresh DEP5 header, update years of packaging
24     copyright.
25   * Set Standards-Version to 3.8.4 (no changes).
26   * Convert to source format 3.0 (quilt). Remove quilt framework.
27     Lower debhelper dependency.
28
29  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
30
31 bti (025-1) unstable; urgency=low
32
33   * New upstream release: 
34     - set default host to twitter (closes: #563098)
35     - mention correct host in prompts (closes: #563099)
36
37  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
38
39 bti (024-1) unstable; urgency=low
40
41   * New upstream release:
42     - do not display password while user types it (LP: #386525)
43     - disable echo when reading the password
44     - add laconica group support
45   * debian/control: add Homepage field and adjust long description.
46   * Use "--with bash-completion" in debian/rules to install bash-completion
47     snippet; bump build dependencies on debhelper and bash-completion in
48     debian/control.
49
50  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
51
52 bti (023-2) unstable; urgency=low
53
54   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
55     Matthias Klose for the pointer.
56   * Set Standards-Version to 3.8.3 (no changes).
57   * Add debian/README.source to document quilt usage.
58   * Simplify debian/rules, adjust versioned build dependencies on debhelper
59     and quilt in debian/control.
60   * Use dh_bash-completion for installing the completion snippet; adjust
61     debian/rules, add a versioned build dependency on bash-completion.
62
63  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
64
65 bti (023-1) unstable; urgency=low
66
67   * New upstream release, main changes:
68     - new 'verbose' mode
69     - SSL also for twitter
70   * debian/copyright: add new additional copyright holder.
71   * Refresh patch manpage-debian.patch.
72   * debian/control: mention additional actions in long description.
73
74  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
75
76 bti (022-1) unstable; urgency=low
77
78   * New upstream release, main changes:
79     - support for custim laconi.ca instances
80     - use SSL for identi.ca
81   * debian/copyright: add additional copyright holder.
82
83  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
84
85 bti (021-1) unstable; urgency=low
86
87   * New upstream release, contains changes in autoconf tools:
88     - simplify debian/rules and debian/install
89     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
90
91  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
92
93 bti (020-1) unstable; urgency=low
94
95   * New upstream release:
96     - remove patch getopt.patch, included upstream
97     - remove manpage for bti-shrink-urls from debian/, included upstream
98     - upstream uses autoconf, adjust debian/rules and debian/install, remove
99       debian/manpages
100
101  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
102
103 bti (017-1) unstable; urgency=low
104
105   * New upstream release.
106   * Add build-dependency on libpcre3-dev.
107   * Refresh patch manpage-debian.patch.
108   * debian/install: add new bti-shrink-urls.
109   * debian/copyright: add information about bti-shrink-urls.
110   * Create a manpage for bti-shrink-urls.
111   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
112     target which is not easier to use than the manual installation we've been
113     using).
114   * Add a new patch getopt.patch to make the new commandline options available
115     in bti.c.
116
117  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
118
119 bti (015-1) unstable; urgency=low
120
121   * New upstream release; from the RELEASE-NOTES:
122     "--action support, bti now can output data from the twitter
123     and identica servers".
124   * Add build dependency on libxml2-dev.
125   * Refresh patch manpage-debian.patch.
126   * Set Standards-Version to 3.8.1 (no changes).
127
128  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
129
130 bti (014-1) unstable; urgency=low
131
132   * New upstream release.
133
134  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
135
136 bti (013-1) unstable; urgency=low
137
138   * New upstream release.
139   * Use dh_install instead of dh_bash-completion to install the bash
140     completion snippet in order to work around a problem on the amd64 buildd
141     (closes: #513115). Drop build dependency on bash-completion.
142
143  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
144
145 bti (012-1) unstable; urgency=low
146
147   * New upstream release.
148   * Install the new bash completion script; add bash-completion to
149     Build-Depends and Suggests.
150   * Refresh patch manpage-debian.patch.
151
152  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
153
154 bti (011-1) unstable; urgency=low
155
156   * New upstream release.
157   * Add build dependency on libreadline5-dev.
158
159  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
160
161 bti (010-1) unstable; urgency=low
162
163   * New upstream release, includes a new --proxy option and honours the
164     http_proxy environment variable (closes: #511087).
165   * Refresh patch manpage-debian.patch.
166
167  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
168
169 bti (008-1) unstable; urgency=low
170
171   * New upstream release (due to december twitter server change).
172   * Update years of packaging copyright.
173
174  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
175
176 bti (007-1) unstable; urgency=low
177
178   * New upstream release.
179
180  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
181
182 bti (006-1) unstable; urgency=low
183
184   * Initial release (Closes: #503241)
185
186  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200