Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
[debian/bti.git] / debian / changelog
1 bti (028-2) UNRELEASED; urgency=low
2
3   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
4     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
5     request_token URI in order to make OAuth work with identi.ca
6     (closes: #602507).
7
8  -- gregor herrmann <gregoa@debian.org>  Tue, 23 Nov 2010 21:01:58 +0100
9
10 bti (028-1) unstable; urgency=low
11
12   * New upstream release:
13     - support for replying to notices
14     - adds OAuth support for both twitter and identi.ca (closes: #588235)
15     - split --background from --bash, and make the latter imply the former
16   * Refresh manpage-debian.patch.
17   * Set Standards-Version to 3.9.1 (no changes).
18   * Add build dependency on liboauth-dev.
19   * debian/rules: switch order of dh arguments (preparation for dh8).
20   * debian/copyright: update years of upstream copyright.
21   * Add README.Debian about OAuth usage.
22
23  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
24
25 bti (026-1) unstable; urgency=low
26
27   * Bump build dependency on bash-completion (needed for --with
28     bash-completion in debian/rules).
29
30   * New upstream release.
31   * Refresh patch manpage-debian.patch and DEP3 patch headers.
32   * debian/copyright: refresh DEP5 header, update years of packaging
33     copyright.
34   * Set Standards-Version to 3.8.4 (no changes).
35   * Convert to source format 3.0 (quilt). Remove quilt framework.
36     Lower debhelper dependency.
37
38  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
39
40 bti (025-1) unstable; urgency=low
41
42   * New upstream release: 
43     - set default host to twitter (closes: #563098)
44     - mention correct host in prompts (closes: #563099)
45
46  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
47
48 bti (024-1) unstable; urgency=low
49
50   * New upstream release:
51     - do not display password while user types it (LP: #386525)
52     - disable echo when reading the password
53     - add laconica group support
54   * debian/control: add Homepage field and adjust long description.
55   * Use "--with bash-completion" in debian/rules to install bash-completion
56     snippet; bump build dependencies on debhelper and bash-completion in
57     debian/control.
58
59  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
60
61 bti (023-2) unstable; urgency=low
62
63   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
64     Matthias Klose for the pointer.
65   * Set Standards-Version to 3.8.3 (no changes).
66   * Add debian/README.source to document quilt usage.
67   * Simplify debian/rules, adjust versioned build dependencies on debhelper
68     and quilt in debian/control.
69   * Use dh_bash-completion for installing the completion snippet; adjust
70     debian/rules, add a versioned build dependency on bash-completion.
71
72  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
73
74 bti (023-1) unstable; urgency=low
75
76   * New upstream release, main changes:
77     - new 'verbose' mode
78     - SSL also for twitter
79   * debian/copyright: add new additional copyright holder.
80   * Refresh patch manpage-debian.patch.
81   * debian/control: mention additional actions in long description.
82
83  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
84
85 bti (022-1) unstable; urgency=low
86
87   * New upstream release, main changes:
88     - support for custim laconi.ca instances
89     - use SSL for identi.ca
90   * debian/copyright: add additional copyright holder.
91
92  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
93
94 bti (021-1) unstable; urgency=low
95
96   * New upstream release, contains changes in autoconf tools:
97     - simplify debian/rules and debian/install
98     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
99
100  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
101
102 bti (020-1) unstable; urgency=low
103
104   * New upstream release:
105     - remove patch getopt.patch, included upstream
106     - remove manpage for bti-shrink-urls from debian/, included upstream
107     - upstream uses autoconf, adjust debian/rules and debian/install, remove
108       debian/manpages
109
110  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
111
112 bti (017-1) unstable; urgency=low
113
114   * New upstream release.
115   * Add build-dependency on libpcre3-dev.
116   * Refresh patch manpage-debian.patch.
117   * debian/install: add new bti-shrink-urls.
118   * debian/copyright: add information about bti-shrink-urls.
119   * Create a manpage for bti-shrink-urls.
120   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
121     target which is not easier to use than the manual installation we've been
122     using).
123   * Add a new patch getopt.patch to make the new commandline options available
124     in bti.c.
125
126  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
127
128 bti (015-1) unstable; urgency=low
129
130   * New upstream release; from the RELEASE-NOTES:
131     "--action support, bti now can output data from the twitter
132     and identica servers".
133   * Add build dependency on libxml2-dev.
134   * Refresh patch manpage-debian.patch.
135   * Set Standards-Version to 3.8.1 (no changes).
136
137  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
138
139 bti (014-1) unstable; urgency=low
140
141   * New upstream release.
142
143  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
144
145 bti (013-1) unstable; urgency=low
146
147   * New upstream release.
148   * Use dh_install instead of dh_bash-completion to install the bash
149     completion snippet in order to work around a problem on the amd64 buildd
150     (closes: #513115). Drop build dependency on bash-completion.
151
152  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
153
154 bti (012-1) unstable; urgency=low
155
156   * New upstream release.
157   * Install the new bash completion script; add bash-completion to
158     Build-Depends and Suggests.
159   * Refresh patch manpage-debian.patch.
160
161  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
162
163 bti (011-1) unstable; urgency=low
164
165   * New upstream release.
166   * Add build dependency on libreadline5-dev.
167
168  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
169
170 bti (010-1) unstable; urgency=low
171
172   * New upstream release, includes a new --proxy option and honours the
173     http_proxy environment variable (closes: #511087).
174   * Refresh patch manpage-debian.patch.
175
176  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
177
178 bti (008-1) unstable; urgency=low
179
180   * New upstream release (due to december twitter server change).
181   * Update years of packaging copyright.
182
183  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
184
185 bti (007-1) unstable; urgency=low
186
187   * New upstream release.
188
189  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
190
191 bti (006-1) unstable; urgency=low
192
193   * Initial release (Closes: #503241)
194
195  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200