New upstream release.
[debian/bti.git] / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/quilt/quilt.make
4
5 build: build-stamp
6 build-stamp: $(QUILT_STAMPFN)
7         dh build --before dh_auto_build
8         [ -f bti.1 ] || xmlto man bti.xml
9         [ -f bti-shrink-urls.1 ] || xmlto man bti-shrink-urls.xml
10         dh build --remaining
11         touch $@
12
13 clean: unpatch
14         dh $@
15
16 install: install-stamp
17 install-stamp: build-stamp
18         dh install
19         mv debian/bti/etc/bash_completion.d/bti-bashcompletion debian/bti/etc/bash_completion.d/bti
20         touch $@
21
22 binary-arch: install
23         dh $@
24
25 binary-indep:
26
27 binary: binary-arch binary-indep
28
29 .PHONY: binary binary-arch binary-indep install clean build