- remove patch getopt.patch, included upstream
[debian/bti.git] / debian / changelog
1 bti (020-1) UNRELEASED; urgency=low
2
3   * New upstream release:
4     - remove patch getopt.patch, included upstream
5     - remove manpage for bti-shrink-urls from debian/, included upstream
6
7  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 18:10:46 +0200
8
9 bti (017-1) unstable; urgency=low
10
11   * New upstream release.
12   * Add build-dependency on libpcre3-dev.
13   * Refresh patch manpage-debian.patch.
14   * debian/install: add new bti-shrink-urls.
15   * debian/copyright: add information about bti-shrink-urls.
16   * Create a manpage for bti-shrink-urls.
17   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
18     target which is not easier to use than the manual installation we've been
19     using).
20   * Add a new patch getopt.patch to make the new commandline options available
21     in bti.c.
22
23  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
24
25 bti (015-1) unstable; urgency=low
26
27   * New upstream release; from the RELEASE-NOTES:
28     "--action support, bti now can output data from the twitter
29     and identica servers".
30   * Add build dependency on libxml2-dev.
31   * Refresh patch manpage-debian.patch.
32   * Set Standards-Version to 3.8.1 (no changes).
33
34  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
35
36 bti (014-1) unstable; urgency=low
37
38   * New upstream release.
39
40  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
41
42 bti (013-1) unstable; urgency=low
43
44   * New upstream release.
45   * Use dh_install instead of dh_bash-completion to install the bash
46     completion snippet in order to work around a problem on the amd64 buildd
47     (closes: #513115). Drop build dependency on bash-completion.
48
49  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
50
51 bti (012-1) unstable; urgency=low
52
53   * New upstream release.
54   * Install the new bash completion script; add bash-completion to
55     Build-Depends and Suggests.
56   * Refresh patch manpage-debian.patch.
57
58  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
59
60 bti (011-1) unstable; urgency=low
61
62   * New upstream release.
63   * Add build dependency on libreadline5-dev.
64
65  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
66
67 bti (010-1) unstable; urgency=low
68
69   * New upstream release, includes a new --proxy option and honours the
70     http_proxy environment variable (closes: #511087).
71   * Refresh patch manpage-debian.patch.
72
73  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
74
75 bti (008-1) unstable; urgency=low
76
77   * New upstream release (due to december twitter server change).
78   * Update years of packaging copyright.
79
80  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
81
82 bti (007-1) unstable; urgency=low
83
84   * New upstream release.
85
86  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
87
88 bti (006-1) unstable; urgency=low
89
90   * Initial release (Closes: #503241)
91
92  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200