debian/copyright: update years of upstream copyright.
[debian/bti.git] / debian / changelog
1 bti (028-1) UNRELEASED; urgency=low
2
3   WAITS-FOR: liboauth # #581601
4
5   * New upstream release:
6     - support for replying to notices
7     - adds OAuth support for both twitter and identi.ca (closes: #588235)
8   * Refresh manpage-debian.patch.
9   * Set Standards-Version to 3.9.1 (no changes).
10   * Add build dependency on liboauth-dev.
11   * debian/rules:
12     - add include path for libxml2 to CFLAGS
13     - switch order of dh arguments (preparation for dh8)
14   * debian/copyright: update years of upstream copyright.
15
16  -- gregor herrmann <gregoa@debian.org>  Fri, 03 Sep 2010 01:11:57 +0200
17
18 bti (026-1) unstable; urgency=low
19
20   * Bump build dependency on bash-completion (needed for --with
21     bash-completion in debian/rules).
22
23   * New upstream release.
24   * Refresh patch manpage-debian.patch and DEP3 patch headers.
25   * debian/copyright: refresh DEP5 header, update years of packaging
26     copyright.
27   * Set Standards-Version to 3.8.4 (no changes).
28   * Convert to source format 3.0 (quilt). Remove quilt framework.
29     Lower debhelper dependency.
30
31  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
32
33 bti (025-1) unstable; urgency=low
34
35   * New upstream release: 
36     - set default host to twitter (closes: #563098)
37     - mention correct host in prompts (closes: #563099)
38
39  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
40
41 bti (024-1) unstable; urgency=low
42
43   * New upstream release:
44     - do not display password while user types it (LP: #386525)
45     - disable echo when reading the password
46     - add laconica group support
47   * debian/control: add Homepage field and adjust long description.
48   * Use "--with bash-completion" in debian/rules to install bash-completion
49     snippet; bump build dependencies on debhelper and bash-completion in
50     debian/control.
51
52  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
53
54 bti (023-2) unstable; urgency=low
55
56   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
57     Matthias Klose for the pointer.
58   * Set Standards-Version to 3.8.3 (no changes).
59   * Add debian/README.source to document quilt usage.
60   * Simplify debian/rules, adjust versioned build dependencies on debhelper
61     and quilt in debian/control.
62   * Use dh_bash-completion for installing the completion snippet; adjust
63     debian/rules, add a versioned build dependency on bash-completion.
64
65  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
66
67 bti (023-1) unstable; urgency=low
68
69   * New upstream release, main changes:
70     - new 'verbose' mode
71     - SSL also for twitter
72   * debian/copyright: add new additional copyright holder.
73   * Refresh patch manpage-debian.patch.
74   * debian/control: mention additional actions in long description.
75
76  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
77
78 bti (022-1) unstable; urgency=low
79
80   * New upstream release, main changes:
81     - support for custim laconi.ca instances
82     - use SSL for identi.ca
83   * debian/copyright: add additional copyright holder.
84
85  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
86
87 bti (021-1) unstable; urgency=low
88
89   * New upstream release, contains changes in autoconf tools:
90     - simplify debian/rules and debian/install
91     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
92
93  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
94
95 bti (020-1) unstable; urgency=low
96
97   * New upstream release:
98     - remove patch getopt.patch, included upstream
99     - remove manpage for bti-shrink-urls from debian/, included upstream
100     - upstream uses autoconf, adjust debian/rules and debian/install, remove
101       debian/manpages
102
103  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
104
105 bti (017-1) unstable; urgency=low
106
107   * New upstream release.
108   * Add build-dependency on libpcre3-dev.
109   * Refresh patch manpage-debian.patch.
110   * debian/install: add new bti-shrink-urls.
111   * debian/copyright: add information about bti-shrink-urls.
112   * Create a manpage for bti-shrink-urls.
113   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
114     target which is not easier to use than the manual installation we've been
115     using).
116   * Add a new patch getopt.patch to make the new commandline options available
117     in bti.c.
118
119  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
120
121 bti (015-1) unstable; urgency=low
122
123   * New upstream release; from the RELEASE-NOTES:
124     "--action support, bti now can output data from the twitter
125     and identica servers".
126   * Add build dependency on libxml2-dev.
127   * Refresh patch manpage-debian.patch.
128   * Set Standards-Version to 3.8.1 (no changes).
129
130  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
131
132 bti (014-1) unstable; urgency=low
133
134   * New upstream release.
135
136  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
137
138 bti (013-1) unstable; urgency=low
139
140   * New upstream release.
141   * Use dh_install instead of dh_bash-completion to install the bash
142     completion snippet in order to work around a problem on the amd64 buildd
143     (closes: #513115). Drop build dependency on bash-completion.
144
145  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
146
147 bti (012-1) unstable; urgency=low
148
149   * New upstream release.
150   * Install the new bash completion script; add bash-completion to
151     Build-Depends and Suggests.
152   * Refresh patch manpage-debian.patch.
153
154  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
155
156 bti (011-1) unstable; urgency=low
157
158   * New upstream release.
159   * Add build dependency on libreadline5-dev.
160
161  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
162
163 bti (010-1) unstable; urgency=low
164
165   * New upstream release, includes a new --proxy option and honours the
166     http_proxy environment variable (closes: #511087).
167   * Refresh patch manpage-debian.patch.
168
169  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
170
171 bti (008-1) unstable; urgency=low
172
173   * New upstream release (due to december twitter server change).
174   * Update years of packaging copyright.
175
176  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
177
178 bti (007-1) unstable; urgency=low
179
180   * New upstream release.
181
182  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
183
184 bti (006-1) unstable; urgency=low
185
186   * Initial release (Closes: #503241)
187
188  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200