releasing package bti version 032-2
[debian/bti.git] / debian / changelog
1 bti (032-2) unstable; urgency=low
2
3   * Update Vcs-* headers.
4   * debian/watch: update after github URL schema change.
5   * Build depend on libcurl4-gnutls-dev instead of libcurl4-nss-dev (cf.
6     #650138) and make build dependency on liboauth-dev versioned just in
7     case). (LP: #1072720)
8   * Remove version from bash-completion build dependency, nothing older in
9     the archive.
10   * debian/copyright: switch formatting to Copyright-Format 1.0.
11   * Update years of packaging copyright.
12   * Set Standards-Version to 3.9.4 (no changes).
13   * Bump debhelper compatibility level to 9.
14   * debian/rules: make build non-silent.
15
16  -- gregor herrmann <gregoa@debian.org>  Mon, 06 May 2013 21:27:22 +0200
17
18 bti (032-1) unstable; urgency=low
19
20   * New upstream release
21   * debian/watch: use github redirector, there are no released tarballs at the
22     moment.
23   * The tarball from github doesn't ship a configure script; use
24     dh-autoreconf.
25   * Refresh patch manpage-debian.patch (offset), drop remaining patches (all
26     included upstream).
27
28  -- gregor herrmann <gregoa@debian.org>  Sat, 03 Dec 2011 01:25:55 +0100
29
30 bti (031-4) unstable; urgency=low
31
32   * Build-depend on libcurl4-nss-dev instead of libcurl4-gnutls-dev; they
33     conflict with each other, and liboauth-dev now requires the former.
34     (Fixes a not-yet-detected FTBFS.)
35
36  -- gregor herrmann <gregoa@debian.org>  Sat, 26 Nov 2011 23:53:14 +0100
37
38 bti (031-3) unstable; urgency=low
39
40   * Add patch to output the correct configfile name (identi.ca/OAuth/access
41     tokens). Thanks to Vincent Lefevre for the bug report; closes: #646681.
42
43  -- gregor herrmann <gregoa@debian.org>  Sat, 05 Nov 2011 17:48:05 +0100
44
45 bti (031-2) unstable; urgency=low
46
47   * New patch debian/patches/identi.ca-oauth.patch: change identica_* OAuth
48     URI's to point to https instead of http (closes: #602507).
49   * Set Standards-Version to 3.9.2 (no changes).
50   * Improve long description.
51
52  -- gregor herrmann <gregoa@debian.org>  Tue, 25 Oct 2011 20:35:48 +0200
53
54 bti (031-1) unstable; urgency=low
55
56   * New upstream release:
57     - addresses "bti doesn't warn if the password is incorrect": check server
58       replies in non-background mode, only in non-OAuth mode
59       (partly solves #602502)
60
61  -- gregor herrmann <gregoa@debian.org>  Tue, 22 Mar 2011 17:18:10 +0100
62
63 bti (030-1) unstable; urgency=low
64
65   * New upstream release.
66   * Switch to debhelper 8.
67
68  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
69
70 bti (029-2) unstable; urgency=low
71
72   * Upload to unstable.
73
74  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
75
76 bti (029-1) experimental; urgency=low
77
78   * New upstream release: includes fixes for
79     + "the --dry-run option has no effect (tweets get posted anyway)
80        with OAuth" (closes: #608608)
81     + "--replyto doesn't work with OAuth" (closes: #608112)
82   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
83     description and add a patch to change the name in the manpage and the
84     example config; thanks to Julien Valroff for the bug report
85     (closes: #605407).
86   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
87     upstream.
88   * Refresh remaining patches.
89   * debian/copyright: update years of upstream and packaging copyright; update
90     formatting.
91   * Don't install README anymore.
92   * Upload to experimental because of the freeze.
93
94  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
95
96 bti (028-2) unstable; urgency=low
97
98   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
99     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
100     request_token URI in order to make OAuth work with identi.ca
101     (closes: #602507).
102   * Minor fixes in README.Debian.
103
104  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
105
106 bti (028-1) unstable; urgency=low
107
108   * New upstream release:
109     - support for replying to notices
110     - adds OAuth support for both twitter and identi.ca (closes: #588235)
111     - split --background from --bash, and make the latter imply the former
112   * Refresh manpage-debian.patch.
113   * Set Standards-Version to 3.9.1 (no changes).
114   * Add build dependency on liboauth-dev.
115   * debian/rules: switch order of dh arguments (preparation for dh8).
116   * debian/copyright: update years of upstream copyright.
117   * Add README.Debian about OAuth usage.
118
119  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
120
121 bti (026-1) unstable; urgency=low
122
123   * Bump build dependency on bash-completion (needed for --with
124     bash-completion in debian/rules).
125
126   * New upstream release.
127   * Refresh patch manpage-debian.patch and DEP3 patch headers.
128   * debian/copyright: refresh DEP5 header, update years of packaging
129     copyright.
130   * Set Standards-Version to 3.8.4 (no changes).
131   * Convert to source format 3.0 (quilt). Remove quilt framework.
132     Lower debhelper dependency.
133
134  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
135
136 bti (025-1) unstable; urgency=low
137
138   * New upstream release: 
139     - set default host to twitter (closes: #563098)
140     - mention correct host in prompts (closes: #563099)
141
142  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
143
144 bti (024-1) unstable; urgency=low
145
146   * New upstream release:
147     - do not display password while user types it (LP: #386525)
148     - disable echo when reading the password
149     - add laconica group support
150   * debian/control: add Homepage field and adjust long description.
151   * Use "--with bash-completion" in debian/rules to install bash-completion
152     snippet; bump build dependencies on debhelper and bash-completion in
153     debian/control.
154
155  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
156
157 bti (023-2) unstable; urgency=low
158
159   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
160     Matthias Klose for the pointer.
161   * Set Standards-Version to 3.8.3 (no changes).
162   * Add debian/README.source to document quilt usage.
163   * Simplify debian/rules, adjust versioned build dependencies on debhelper
164     and quilt in debian/control.
165   * Use dh_bash-completion for installing the completion snippet; adjust
166     debian/rules, add a versioned build dependency on bash-completion.
167
168  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
169
170 bti (023-1) unstable; urgency=low
171
172   * New upstream release, main changes:
173     - new 'verbose' mode
174     - SSL also for twitter
175   * debian/copyright: add new additional copyright holder.
176   * Refresh patch manpage-debian.patch.
177   * debian/control: mention additional actions in long description.
178
179  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
180
181 bti (022-1) unstable; urgency=low
182
183   * New upstream release, main changes:
184     - support for custim laconi.ca instances
185     - use SSL for identi.ca
186   * debian/copyright: add additional copyright holder.
187
188  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
189
190 bti (021-1) unstable; urgency=low
191
192   * New upstream release, contains changes in autoconf tools:
193     - simplify debian/rules and debian/install
194     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
195
196  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
197
198 bti (020-1) unstable; urgency=low
199
200   * New upstream release:
201     - remove patch getopt.patch, included upstream
202     - remove manpage for bti-shrink-urls from debian/, included upstream
203     - upstream uses autoconf, adjust debian/rules and debian/install, remove
204       debian/manpages
205
206  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
207
208 bti (017-1) unstable; urgency=low
209
210   * New upstream release.
211   * Add build-dependency on libpcre3-dev.
212   * Refresh patch manpage-debian.patch.
213   * debian/install: add new bti-shrink-urls.
214   * debian/copyright: add information about bti-shrink-urls.
215   * Create a manpage for bti-shrink-urls.
216   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
217     target which is not easier to use than the manual installation we've been
218     using).
219   * Add a new patch getopt.patch to make the new commandline options available
220     in bti.c.
221
222  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
223
224 bti (015-1) unstable; urgency=low
225
226   * New upstream release; from the RELEASE-NOTES:
227     "--action support, bti now can output data from the twitter
228     and identica servers".
229   * Add build dependency on libxml2-dev.
230   * Refresh patch manpage-debian.patch.
231   * Set Standards-Version to 3.8.1 (no changes).
232
233  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
234
235 bti (014-1) unstable; urgency=low
236
237   * New upstream release.
238
239  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
240
241 bti (013-1) unstable; urgency=low
242
243   * New upstream release.
244   * Use dh_install instead of dh_bash-completion to install the bash
245     completion snippet in order to work around a problem on the amd64 buildd
246     (closes: #513115). Drop build dependency on bash-completion.
247
248  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
249
250 bti (012-1) unstable; urgency=low
251
252   * New upstream release.
253   * Install the new bash completion script; add bash-completion to
254     Build-Depends and Suggests.
255   * Refresh patch manpage-debian.patch.
256
257  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
258
259 bti (011-1) unstable; urgency=low
260
261   * New upstream release.
262   * Add build dependency on libreadline5-dev.
263
264  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
265
266 bti (010-1) unstable; urgency=low
267
268   * New upstream release, includes a new --proxy option and honours the
269     http_proxy environment variable (closes: #511087).
270   * Refresh patch manpage-debian.patch.
271
272  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
273
274 bti (008-1) unstable; urgency=low
275
276   * New upstream release (due to december twitter server change).
277   * Update years of packaging copyright.
278
279  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
280
281 bti (007-1) unstable; urgency=low
282
283   * New upstream release.
284
285  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
286
287 bti (006-1) unstable; urgency=low
288
289   * Initial release (Closes: #503241)
290
291  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200