releasing package bti version 034-4
[debian/bti.git] / debian / changelog
1 bti (034-4) unstable; urgency=medium
2
3   * Add patch from upstream pull request to remove is_error() macro
4     which is deprecated in json-c 0.13.1 and later removed competely.
5     (Closes: #915839)
6   * Fix Vcs-* fields.
7   * Use HTTPS for Format URL in debian/copyright.
8   * Add debian/upstream/metadata.
9   * Set bindnow linker flag in debian/rules.
10   * Declare compliance with Debian Policy 4.3.0.
11   * Remove unneeded version constraint from build dependency.
12   * Remove trailing whitespace from debian/*.
13   * Add a (superficial) autopkgtest.
14
15  -- gregor herrmann <gregoa@debian.org>  Sun, 23 Dec 2018 23:26:10 +0100
16
17 bti (034-3) unstable; urgency=medium
18
19   * Update debian/control priority to "optional"
20   * Bump Standards-Version to 4.1.4
21   * Use https URLs in debian/control
22   * Bump copyright years in debian/copyright
23   * Use debhelper and compat level 11; drop dh-autoreconf dependency,
24     which is enabled by default since compat level 10.
25
26  -- tony mancill <tmancill@debian.org>  Sun, 01 Jul 2018 08:18:41 -0700
27
28 bti (034-2) unstable; urgency=medium
29
30   * debian/watch: switch upstream URL back to kernel.org.
31   * Also update Source field in debian/copyright.
32   * Add build dependency on pkg-config.
33     Thanks to David Su├írez for the bug report.
34     (Closes: #747771)
35
36  -- gregor herrmann <gregoa@debian.org>  Sun, 11 May 2014 21:01:38 +0200
37
38 bti (034-1) unstable; urgency=medium
39
40   * New upstream release. Important changes:
41     - use https for all Twitter URLs
42       Closes: #735367
43     - drop (already broken) support for StatusNet / identi.ca (which has
44       switched from StatusNet to the never-supported pump.io)
45       Closes: #714330, #717133
46   * debian/*: don't mention identi.ca/StatusNet anymore.
47   * Add patch to remove some more references to identi.ca from the help
48     output and the example config.
49   * Drop two patches (taken from upstream or fixed identically),
50     refresh one (offset).
51   * Update years of packaging copyright.
52   * Declare compliance with Debian Policy 3.9.5.
53
54  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Jan 2014 19:01:33 +0100
55
56 bti (033-2) unstable; urgency=low
57
58   * Add patch use-EIO-instead-of-EREMOTEIO.patch, taken from upstream git.
59     (Closes: #714335)
60
61  -- gregor herrmann <gregoa@debian.org>  Fri, 28 Jun 2013 12:55:53 +0200
62
63 bti (033-1) unstable; urgency=low
64
65   * New upstream release:
66     - fixes "bti should terminate with an error if the --config file can't
67       be read" (Closes: #669192)
68     - fixes "bti no longer works with Twitter and loses posted tweets"
69       by adjusting to the Twitter API v 1.1
70       (Closes: #714032)
71   * Refresh manpage-debian.patch (offset).
72   * Add build dependency on libjson-c-dev.
73   * Add patch to handle Debian's libjson-c.
74   * Add a patch to fix a spelling mistake in the manpage.
75   * Update OAuth instructions on README.Debian. (Closes: #706104)
76   * Update long description (direct messages are supported now).
77
78  -- gregor herrmann <gregoa@debian.org>  Fri, 28 Jun 2013 01:55:26 +0200
79
80 bti (032-2) unstable; urgency=low
81
82   * Update Vcs-* headers.
83   * debian/watch: update after github URL schema change.
84   * Build depend on libcurl4-gnutls-dev instead of libcurl4-nss-dev (cf.
85     #650138) and make build dependency on liboauth-dev versioned just in
86     case). (LP: #1072720)
87   * Remove version from bash-completion build dependency, nothing older in
88     the archive.
89   * debian/copyright: switch formatting to Copyright-Format 1.0.
90   * Update years of packaging copyright.
91   * Set Standards-Version to 3.9.4 (no changes).
92   * Bump debhelper compatibility level to 9.
93   * debian/rules: make build non-silent.
94
95  -- gregor herrmann <gregoa@debian.org>  Mon, 06 May 2013 21:27:22 +0200
96
97 bti (032-1) unstable; urgency=low
98
99   * New upstream release
100   * debian/watch: use github redirector, there are no released tarballs at the
101     moment.
102   * The tarball from github doesn't ship a configure script; use
103     dh-autoreconf.
104   * Refresh patch manpage-debian.patch (offset), drop remaining patches (all
105     included upstream).
106
107  -- gregor herrmann <gregoa@debian.org>  Sat, 03 Dec 2011 01:25:55 +0100
108
109 bti (031-4) unstable; urgency=low
110
111   * Build-depend on libcurl4-nss-dev instead of libcurl4-gnutls-dev; they
112     conflict with each other, and liboauth-dev now requires the former.
113     (Fixes a not-yet-detected FTBFS.)
114
115  -- gregor herrmann <gregoa@debian.org>  Sat, 26 Nov 2011 23:53:14 +0100
116
117 bti (031-3) unstable; urgency=low
118
119   * Add patch to output the correct configfile name (identi.ca/OAuth/access
120     tokens). Thanks to Vincent Lefevre for the bug report; closes: #646681.
121
122  -- gregor herrmann <gregoa@debian.org>  Sat, 05 Nov 2011 17:48:05 +0100
123
124 bti (031-2) unstable; urgency=low
125
126   * New patch debian/patches/identi.ca-oauth.patch: change identica_* OAuth
127     URI's to point to https instead of http (closes: #602507).
128   * Set Standards-Version to 3.9.2 (no changes).
129   * Improve long description.
130
131  -- gregor herrmann <gregoa@debian.org>  Tue, 25 Oct 2011 20:35:48 +0200
132
133 bti (031-1) unstable; urgency=low
134
135   * New upstream release:
136     - addresses "bti doesn't warn if the password is incorrect": check server
137       replies in non-background mode, only in non-OAuth mode
138       (partly solves #602502)
139
140  -- gregor herrmann <gregoa@debian.org>  Tue, 22 Mar 2011 17:18:10 +0100
141
142 bti (030-1) unstable; urgency=low
143
144   * New upstream release.
145   * Switch to debhelper 8.
146
147  -- gregor herrmann <gregoa@debian.org>  Fri, 18 Mar 2011 12:32:44 +0100
148
149 bti (029-2) unstable; urgency=low
150
151   * Upload to unstable.
152
153  -- gregor herrmann <gregoa@debian.org>  Mon, 07 Feb 2011 18:32:28 +0100
154
155 bti (029-1) experimental; urgency=low
156
157   * New upstream release: includes fixes for
158     + "the --dry-run option has no effect (tweets get posted anyway)
159        with OAuth" (closes: #608608)
160     + "--replyto doesn't work with OAuth" (closes: #608112)
161   * laconi.ca was renamed to StatusNet (in August 2009); adjust package
162     description and add a patch to change the name in the manpage and the
163     example config; thanks to Julien Valroff for the bug report
164     (closes: #605407).
165   * Drop patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch, applied
166     upstream.
167   * Refresh remaining patches.
168   * debian/copyright: update years of upstream and packaging copyright; update
169     formatting.
170   * Don't install README anymore.
171   * Upload to experimental because of the freeze.
172
173  -- gregor herrmann <gregoa@debian.org>  Fri, 14 Jan 2011 02:43:10 +0100
174
175 bti (028-2) unstable; urgency=low
176
177   * Add patch 0001-Fixing-Identi.ca-s-OAuth-request_token-URI.patch by Amir
178     Mohammad Saied which adds the oauth_callback parameter to the identi.ca
179     request_token URI in order to make OAuth work with identi.ca
180     (closes: #602507).
181   * Minor fixes in README.Debian.
182
183  -- gregor herrmann <gregoa@debian.org>  Wed, 24 Nov 2010 18:03:23 +0100
184
185 bti (028-1) unstable; urgency=low
186
187   * New upstream release:
188     - support for replying to notices
189     - adds OAuth support for both twitter and identi.ca (closes: #588235)
190     - split --background from --bash, and make the latter imply the former
191   * Refresh manpage-debian.patch.
192   * Set Standards-Version to 3.9.1 (no changes).
193   * Add build dependency on liboauth-dev.
194   * debian/rules: switch order of dh arguments (preparation for dh8).
195   * debian/copyright: update years of upstream copyright.
196   * Add README.Debian about OAuth usage.
197
198  -- gregor herrmann <gregoa@debian.org>  Wed, 03 Nov 2010 23:00:59 +0100
199
200 bti (026-1) unstable; urgency=low
201
202   * Bump build dependency on bash-completion (needed for --with
203     bash-completion in debian/rules).
204
205   * New upstream release.
206   * Refresh patch manpage-debian.patch and DEP3 patch headers.
207   * debian/copyright: refresh DEP5 header, update years of packaging
208     copyright.
209   * Set Standards-Version to 3.8.4 (no changes).
210   * Convert to source format 3.0 (quilt). Remove quilt framework.
211     Lower debhelper dependency.
212
213  -- gregor herrmann <gregoa@debian.org>  Wed, 19 May 2010 21:41:04 +0200
214
215 bti (025-1) unstable; urgency=low
216
217   * New upstream release:
218     - set default host to twitter (closes: #563098)
219     - mention correct host in prompts (closes: #563099)
220
221  -- gregor herrmann <gregoa@debian.org>  Sun, 10 Jan 2010 01:29:11 +0100
222
223 bti (024-1) unstable; urgency=low
224
225   * New upstream release:
226     - do not display password while user types it (LP: #386525)
227     - disable echo when reading the password
228     - add laconica group support
229   * debian/control: add Homepage field and adjust long description.
230   * Use "--with bash-completion" in debian/rules to install bash-completion
231     snippet; bump build dependencies on debhelper and bash-completion in
232     debian/control.
233
234  -- gregor herrmann <gregoa@debian.org>  Wed, 02 Dec 2009 17:09:28 +0100
235
236 bti (023-2) unstable; urgency=low
237
238   * Build depend on libreadline-dev instead of libreadline5-dev, thanks to
239     Matthias Klose for the pointer.
240   * Set Standards-Version to 3.8.3 (no changes).
241   * Add debian/README.source to document quilt usage.
242   * Simplify debian/rules, adjust versioned build dependencies on debhelper
243     and quilt in debian/control.
244   * Use dh_bash-completion for installing the completion snippet; adjust
245     debian/rules, add a versioned build dependency on bash-completion.
246
247  -- gregor herrmann <gregoa@debian.org>  Sun, 13 Sep 2009 16:14:08 +0200
248
249 bti (023-1) unstable; urgency=low
250
251   * New upstream release, main changes:
252     - new 'verbose' mode
253     - SSL also for twitter
254   * debian/copyright: add new additional copyright holder.
255   * Refresh patch manpage-debian.patch.
256   * debian/control: mention additional actions in long description.
257
258  -- gregor herrmann <gregoa@debian.org>  Thu, 28 May 2009 17:37:08 +0200
259
260 bti (022-1) unstable; urgency=low
261
262   * New upstream release, main changes:
263     - support for custim laconi.ca instances
264     - use SSL for identi.ca
265   * debian/copyright: add additional copyright holder.
266
267  -- gregor herrmann <gregoa@debian.org>  Wed, 06 May 2009 23:05:42 +0200
268
269 bti (021-1) unstable; urgency=low
270
271   * New upstream release, contains changes in autoconf tools:
272     - simplify debian/rules and debian/install
273     - replace xmtlo with xsltproc, docbook-xsl, docbook-xml in debian/control
274
275  -- gregor herrmann <gregoa@debian.org>  Wed, 15 Apr 2009 17:12:53 +0200
276
277 bti (020-1) unstable; urgency=low
278
279   * New upstream release:
280     - remove patch getopt.patch, included upstream
281     - remove manpage for bti-shrink-urls from debian/, included upstream
282     - upstream uses autoconf, adjust debian/rules and debian/install, remove
283       debian/manpages
284
285  -- gregor herrmann <gregoa@debian.org>  Tue, 14 Apr 2009 20:40:24 +0200
286
287 bti (017-1) unstable; urgency=low
288
289   * New upstream release.
290   * Add build-dependency on libpcre3-dev.
291   * Refresh patch manpage-debian.patch.
292   * debian/install: add new bti-shrink-urls.
293   * debian/copyright: add information about bti-shrink-urls.
294   * Create a manpage for bti-shrink-urls.
295   * debian/rules: skip dh_auto_install (upstream Makefile now has an install
296     target which is not easier to use than the manual installation we've been
297     using).
298   * Add a new patch getopt.patch to make the new commandline options available
299     in bti.c.
300
301  -- gregor herrmann <gregoa@debian.org>  Tue, 24 Mar 2009 20:47:41 +0100
302
303 bti (015-1) unstable; urgency=low
304
305   * New upstream release; from the RELEASE-NOTES:
306     "--action support, bti now can output data from the twitter
307     and identica servers".
308   * Add build dependency on libxml2-dev.
309   * Refresh patch manpage-debian.patch.
310   * Set Standards-Version to 3.8.1 (no changes).
311
312  -- gregor herrmann <gregoa@debian.org>  Thu, 12 Mar 2009 17:17:11 +0100
313
314 bti (014-1) unstable; urgency=low
315
316   * New upstream release.
317
318  -- gregor herrmann <gregoa@debian.org>  Sat, 14 Feb 2009 18:36:36 +0100
319
320 bti (013-1) unstable; urgency=low
321
322   * New upstream release.
323   * Use dh_install instead of dh_bash-completion to install the bash
324     completion snippet in order to work around a problem on the amd64 buildd
325     (closes: #513115). Drop build dependency on bash-completion.
326
327  -- gregor herrmann <gregoa@debian.org>  Thu, 05 Feb 2009 20:54:54 +0100
328
329 bti (012-1) unstable; urgency=low
330
331   * New upstream release.
332   * Install the new bash completion script; add bash-completion to
333     Build-Depends and Suggests.
334   * Refresh patch manpage-debian.patch.
335
336  -- gregor herrmann <gregoa@debian.org>  Sun, 25 Jan 2009 00:52:13 +0100
337
338 bti (011-1) unstable; urgency=low
339
340   * New upstream release.
341   * Add build dependency on libreadline5-dev.
342
343  -- gregor herrmann <gregoa@debian.org>  Tue, 20 Jan 2009 17:05:57 +0100
344
345 bti (010-1) unstable; urgency=low
346
347   * New upstream release, includes a new --proxy option and honours the
348     http_proxy environment variable (closes: #511087).
349   * Refresh patch manpage-debian.patch.
350
351  -- gregor herrmann <gregoa@debian.org>  Mon, 12 Jan 2009 22:46:19 +0100
352
353 bti (008-1) unstable; urgency=low
354
355   * New upstream release (due to december twitter server change).
356   * Update years of packaging copyright.
357
358  -- gregor herrmann <gregoa@debian.org>  Sat, 10 Jan 2009 06:01:45 +0100
359
360 bti (007-1) unstable; urgency=low
361
362   * New upstream release.
363
364  -- gregor herrmann <gregoa@debian.org>  Sun, 26 Oct 2008 23:36:48 +0100
365
366 bti (006-1) unstable; urgency=low
367
368   * Initial release (Closes: #503241)
369
370  -- gregor herrmann <gregoa@debian.org>  Fri, 24 Oct 2008 20:53:07 +0200