* Simplify debian/rules, adjust versioned build dependencies on debhelper
[debian/bti.git] / debian / rules
index a6c48c2df332e35ab1199ca5ea8fd5f22411c9f0..11cca89dec2fd1b7813ca6714c0e87347d09cd39 100755 (executable)
@@ -1,26 +1,11 @@
 #!/usr/bin/make -f
 
-include /usr/share/quilt/quilt.make
-
-build: build-stamp
-build-stamp: $(QUILT_STAMPFN)
-       dh build
-       touch $@
-
-clean: unpatch
-       dh $@
-
-install: install-stamp
-install-stamp: build-stamp
-       dh install
-       mv debian/bti/etc/bash_completion.d/bti-bashcompletion debian/bti/etc/bash_completion.d/bti
-       touch $@
-
-binary-arch: install
-       dh $@
-
-binary-indep:
-
-binary: binary-arch binary-indep
-
-.PHONY: binary binary-arch binary-indep install clean build
+%:
+       dh --with quilt $@
+
+# after #535105 is fixed we can use '--with quilt,bash-completion'
+# and need to bump the build dependencies on debhelper and bash-completion;
+# until then, let's simulate the behaviour
+override_dh_installman:
+       dh_installman
+       dh_bash-completion