Switch to debhelper 7, adjust debian/rules and versioned dependencies in