* Set Standards-Version to 3.7.3 (no changes required).
[debian/iodine.git] / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 include /usr/share/dpatch/dpatch.make
13
14 CFLAGS = -Wall -g
15
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17         CFLAGS += -O0
18 else
19         CFLAGS += -O2
20 endif
21
22 configure: configure-stamp
23 configure-stamp: $(DPATCH_STAMPFN)
24         dh_testdir
25         touch $@
26
27 build: build-stamp
28 build-stamp: configure-stamp
29         dh_testdir
30         $(MAKE)
31         $(MAKE) test
32         touch $@
33
34 clean: unpatch
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp configure-stamp install-stamp
38         $(MAKE) clean
39         debconf-updatepo
40         dh_clean
41
42 install: install-stamp
43 install-stamp: build-stamp
44         dh_testdir
45         dh_testroot
46         $(MAKE) install prefix=debian/iodine/usr 
47         touch $@
48
49
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
53
54 # Build architecture-dependent files here.
55 binary-arch: build install
56         dh_testdir
57         dh_testroot
58         dh_installchangelogs CHANGELOG
59         dh_installdocs README
60         dh_installdebconf       
61         dh_installinit --name=iodined
62         dh_link usr/share/man/man8/iodine.8 usr/share/man/man8/iodined.8
63         dh_strip
64         dh_compress
65         dh_fixperms
66         dh_installdeb
67         dh_shlibdeps
68         dh_gencontrol
69         dh_md5sums
70         dh_builddeb
71
72 binary: binary-indep binary-arch
73 .PHONY: build clean binary-indep binary-arch binary install configure