3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
12 include /usr/share/dpatch/dpatch.make
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22 configure: configure-stamp
23 configure-stamp: $(DPATCH_STAMPFN)
28 build-stamp: configure-stamp
37 rm -f build-stamp configure-stamp install-stamp
42 install: install-stamp
43 install-stamp: build-stamp
46 $(MAKE) install prefix=debian/iodine/usr
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build install
58 dh_installchangelogs CHANGELOG
61 dh_installinit --name=iodined
62 dh_link usr/share/man/man8/iodine.8 usr/share/man/man8/iodined.8
72 binary: binary-indep binary-arch
73 .PHONY: build clean binary-indep binary-arch binary install configure