[svn-inject] Applying Debian modifications to trunk
[debian/iodine.git] / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 CFLAGS = -Wall -g
13
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15         CFLAGS += -O0
16 else
17         CFLAGS += -O2
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22         dh_testdir
23         touch configure-stamp
24
25 build: build-stamp
26
27 build-stamp: configure-stamp
28         dh_testdir
29         $(MAKE)
30         help2man ./iodine --name="IP over DNS tunneling client" --section=8 --source=iodine --no-info --help-option=-h --version-option=-v --output=debian/iodine.8
31         help2man ./iodined --name="IP over DNS tunneling server" --section=8 --source=iodined --no-info --help-option=-h --version-option=-v --output=debian/iodined.8
32         touch $@
33
34 clean:
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp configure-stamp
38
39         # Add here commands to clean up after the build process.
40         $(MAKE) clean
41         dh_clean debian/iodine.8 debian/iodined.8
42
43 install: build
44         dh_testdir
45         dh_testroot
46         dh_clean -k 
47         dh_installdirs
48
49
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
53
54 # Build architecture-dependent files here.
55 binary-arch: build install
56         dh_testdir
57         dh_testroot
58         dh_installchangelogs CHANGELOG
59         dh_installdocs
60 #       dh_installexamples
61         dh_install
62 #       dh_installmenu
63         dh_installdebconf       
64 #       dh_installlogrotate
65 #       dh_installemacsen
66 #       dh_installpam
67 #       dh_installmime
68 #       dh_python
69         dh_installinit --name=iodine
70         dh_installinit --name=iodined
71 #       dh_installcron
72 #       dh_installinfo
73         dh_installman debian/iodine.8 debian/iodined.8
74         dh_link
75         dh_strip
76         dh_compress
77         dh_fixperms
78 #       dh_perl
79 #       dh_makeshlibs
80         dh_installdeb
81         dh_shlibdeps
82         dh_gencontrol
83         dh_md5sums
84         dh_builddeb
85
86 binary: binary-indep binary-arch
87 .PHONY: build clean binary-indep binary-arch binary install configure