3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 configure: configure-stamp
27 build-stamp: configure-stamp
30 help2man ./iodine --name="IP over DNS tunneling client" --section=8 --source=iodine --no-info --help-option=-h --version-option=-v --output=debian/iodine.8
31 help2man ./iodined --name="IP over DNS tunneling server" --section=8 --source=iodined --no-info --help-option=-h --version-option=-v --output=debian/iodined.8
37 rm -f build-stamp configure-stamp
39 # Add here commands to clean up after the build process.
41 dh_clean debian/iodine.8 debian/iodined.8
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build install
58 dh_installchangelogs CHANGELOG
69 dh_installinit --name=iodine
70 dh_installinit --name=iodined
73 dh_installman debian/iodine.8 debian/iodined.8
86 binary: binary-indep binary-arch
87 .PHONY: build clean binary-indep binary-arch binary install configure