update branches/2.5 from beta1 to the 2.5 release
[debian/jabref.git] / debian / patches / 04_HONOR_DISPLAY_PROPERTIES.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 04_HONOR_DISPLAY_PROPERTIES.dpatch by  <gregor+debian@comodo.priv.at>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: JEditorPane.HONOR_DISPLAY_PROPERTIES not understood by java-gcj-compat-dev ...
6
7 @DPATCH@
8 diff -urNad jabref~/src/java/net/sf/jabref/JabRefMain.java jabref/src/java/net/sf/jabref/JabRefMain.java
9 --- jabref~/src/java/net/sf/jabref/JabRefMain.java      2007-10-08 21:51:47.000000000 +0200
10 +++ jabref/src/java/net/sf/jabref/JabRefMain.java       2007-10-09 18:55:12.000000000 +0200
11 @@ -109,7 +109,6 @@
12                  "We are sorry for the trouble and thanks for reporting problems with JabRef!</html>");\r
13              pane.setEditable(false);\r
14              pane.setOpaque(false);\r
15 -            pane.putClientProperty(JEditorPane.HONOR_DISPLAY_PROPERTIES, Boolean.TRUE);\r
16              \r
17              Component componentToDisplay;\r
18              if (pane.getPreferredSize().getHeight() > 700){\r
19 @@ -157,7 +156,6 @@
20                  "<p>For more information visit <b>http://jabref.sf.net/faq.php</b>.</p></html>");\r
21              pane.setEditable(false);\r
22              pane.setOpaque(false);\r
23 -            pane.putClientProperty(JEditorPane.HONOR_DISPLAY_PROPERTIES, Boolean.TRUE);\r
24              \r
25              JOptionPane.showMessageDialog(null, pane, "Insufficient Java Version Installed", JOptionPane.ERROR_MESSAGE);\r
26          }\r