add epoch to new dep versions
[debian/jabref.git] / debian / patches / 01_free_javac.patch
1 Author: gregor herrmann <gregoa@debian.org>
2 Author: Philip Rinn <rinni@gmx.net>
3 Description: Changes to be able to compile JabRef with free java compilers.
4 --- a/src/java/net/sf/jabref/JabRef.java
5 +++ b/src/java/net/sf/jabref/JabRef.java
6 @@ -29,7 +29,6 @@ import com.jgoodies.looks.FontPolicy;
7  import com.jgoodies.looks.FontSet;
8  import com.jgoodies.looks.FontSets;
9  import com.jgoodies.looks.plastic.Plastic3DLookAndFeel;
10 -import com.jgoodies.looks.windows.WindowsLookAndFeel;
11  import gnu.dtools.ritopt.BooleanOption;
12  import gnu.dtools.ritopt.Options;
13  import gnu.dtools.ritopt.StringOption;
14 @@ -606,27 +605,6 @@ public class JabRef {
15  
16                      //Plastic3DLookAndFeel plLnf = (Plastic3DLookAndFeel) lnf;
17                  }
18 -                else if ((lnf != null) && (lnf instanceof WindowsLookAndFeel)) {
19 -
20 -                    // Set a "model" icon size, so menu items are evenly spaced even though
21 -                    // only some items have icons. We load an arbitrary icon and look at
22 -                    // its size to determine what size to use:
23 -                    int defaultIconSize = GUIGlobals.getImage("open").getIconWidth();
24 -                    com.jgoodies.looks.Options.setDefaultIconSize
25 -                        (new Dimension(defaultIconSize, defaultIconSize));
26 -
27 -                    if (overrideDefaultFonts) {
28 -                        FontSet fontSet = FontSets.createDefaultFontSet(
29 -                            new Font("Tahoma", Font.PLAIN, fontSizes),    // control font
30 -                            new Font("Tahoma", Font.PLAIN, fontSizes),    // menu font
31 -                            new Font("Tahoma", Font.BOLD, fontSizes)     // title font
32 -                            );
33 -                        FontPolicy fixedPolicy = FontPolicies.createFixedPolicy(fontSet);
34 -                        WindowsLookAndFeel.setFontPolicy(fixedPolicy);
35 -                    }
36 -
37 -                    //WindowsLookAndFeel plLnf = (WindowsLookAndFeel) lnf;
38 -                }
39  
40                  if (lnf != null) {
41                      try {