erm, moved call to install-doc to correct package
authorgregor herrmann <gregoa@debian.org>
Sun, 21 May 2006 14:28:03 +0000 (14:28 -0000)
committergregor herrmann <gregoa@debian.org>
Sun, 21 May 2006 14:28:03 +0000 (14:28 -0000)
debian/libmimetic-dev.postinst [deleted file]
debian/libmimetic-dev.prerm [deleted file]
debian/libmimetic-doc.postinst [new file with mode: 0644]
debian/libmimetic-doc.prerm [new file with mode: 0644]

diff --git a/debian/libmimetic-dev.postinst b/debian/libmimetic-dev.postinst
deleted file mode 100644 (file)
index 31f91cd..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#! /bin/sh
-# postinst script for fullquottel
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-#        * <postinst> `configure' <most-recently-configured-version>
-#        * <old-postinst> `abort-upgrade' <new version>
-#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-#          <new-version>
-#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-#          <failed-install-package> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-#
-
-case "$1" in
-    configure)
-      if which install-docs >/dev/null 2>&1; then
-        install-docs -i /usr/share/doc-base/mimetic-doc
-      fi
-    ;;
-
-    abort-upgrade|abort-remove|abort-deconfigure)
-    ;;
-
-    *)
-      echo "postinst called with unknown argument \`$1'" >&2
-      exit 1
-    ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
diff --git a/debian/libmimetic-dev.prerm b/debian/libmimetic-dev.prerm
deleted file mode 100644 (file)
index 75c8e47..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#! /bin/sh
-# prerm script for fullquottel
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-#        * <prerm> `remove'
-#        * <old-prerm> `upgrade' <new-version>
-#        * <new-prerm> `failed-upgrade' <old-version>
-#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-#        * <deconfigured's-prerm> `deconfigure' `in-favour'
-#          <package-being-installed> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
-    remove|upgrade|deconfigure)
-      if which install-docs >/dev/null 2>&1; then
-        install-docs -r mimetic-doc
-      fi
-    ;;
-
-    failed-upgrade)
-    ;;
-    
-    *)
-      echo "prerm called with unknown argument \`$1'" >&2
-      exit 1
-    ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
diff --git a/debian/libmimetic-doc.postinst b/debian/libmimetic-doc.postinst
new file mode 100644 (file)
index 0000000..31f91cd
--- /dev/null
@@ -0,0 +1,43 @@
+#! /bin/sh
+# postinst script for fullquottel
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+#
+
+case "$1" in
+    configure)
+      if which install-docs >/dev/null 2>&1; then
+        install-docs -i /usr/share/doc-base/mimetic-doc
+      fi
+    ;;
+
+    abort-upgrade|abort-remove|abort-deconfigure)
+    ;;
+
+    *)
+      echo "postinst called with unknown argument \`$1'" >&2
+      exit 1
+    ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/libmimetic-doc.prerm b/debian/libmimetic-doc.prerm
new file mode 100644 (file)
index 0000000..75c8e47
--- /dev/null
@@ -0,0 +1,43 @@
+#! /bin/sh
+# prerm script for fullquottel
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <prerm> `remove'
+#        * <old-prerm> `upgrade' <new-version>
+#        * <new-prerm> `failed-upgrade' <old-version>
+#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
+#        * <deconfigured's-prerm> `deconfigure' `in-favour'
+#          <package-being-installed> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+    remove|upgrade|deconfigure)
+      if which install-docs >/dev/null 2>&1; then
+        install-docs -r mimetic-doc
+      fi
+    ;;
+
+    failed-upgrade)
+    ;;
+    
+    *)
+      echo "prerm called with unknown argument \`$1'" >&2
+      exit 1
+    ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+