Update Vcs-* headers.
[debian/quickappoint.git] / cgi-bin / auth.php
1 <?php
2 require_once(dirname(__FILE__) . '/../lib/prepend.php');
3 if (!isset($_POST['username']) || !isset($_POST['password'])) die('invalid post parameter');
4
5
6 require_once(dirname(__FILE__) . '/../lib/dblogic.php');
7 $persondata = getPersonData($_POST['username'], $_POST['password']);
8
9 if ($persondata) {
10         // success
11         $_SESSION['person'] = $persondata;
12         header('Location:' . $project_options['projecturl'] . 'overview.php');
13 } else {
14         // no success
15         unset($_SESSION['person']);
16         $errormsg = _('username/password combination not valid!');
17         $_SESSION['errormsg'] = $errormsg;
18         header('Location:' . $project_options['projecturl'] . 'login.php');
19 }
20
21 ?>