C++98 compatibility: Variable initialization in TransactionRaii class.
[toast/confclerk.git] / confclerk.pro
index a8ff1b01d53373c4cd35ad531cd421fc889b54fa..8171399115a896841ef6b34dc6cb0fe3584a7008 100644 (file)
@@ -3,7 +3,7 @@
 QMAKEVERSION = $$[QMAKE_VERSION]
 ISQT4 = $$find(QMAKEVERSION, ^[2-9])
 isEmpty( ISQT4 ) {
-       error("Use the qmake include with Qt4.4 or greater, on Debian that is qmake-qt4");
+       error("Use the qmake include with Qt4.7 or greater, on Debian that is qmake-qt4");
 }
 
 TEMPLATE = subdirs
@@ -16,11 +16,11 @@ QMAKE_EXTRA_TARGETS += changelog icon man release releaseclean tarball signature
 
 changelog.target = ChangeLog
 changelog.commands = \
-       svn up && svn2cl --group-by-day --reparagraph
+       git pull && /usr/share/gnulib/build-aux/gitlog-to-changelog > ChangeLog
 changelog.CONFIG = phony
 
 icon.target = data/$${TARGET}.png
-icon.commands = convert data/$${TARGET}.svg data/$${TARGET}.png
+icon.commands = convert -transparent white data/$${TARGET}.svg data/$${TARGET}.png
 icon.depends = data/$${TARGET}.svg
 
 man.target = data/$${TARGET}.1
@@ -42,7 +42,7 @@ tarball.commands = \
                $${TARGET}-$${VERSION}/$${TARGET}-$${VERSION}.tar.gz \
                $(DEL_FILE) -r $${TARGET}-$${VERSION}/$${TARGET}-$${VERSION} \
                $${TARGET}-$${VERSION}/Makefile ; \
-       tar -cz --exclude=.svn --exclude=*.tar.gz -f $$tarball.target $${TARGET}-$${VERSION} ; \
+       tar -cz --exclude=.svn --exclude=.git --exclude=*.tar.gz -f $$tarball.target $${TARGET}-$${VERSION} ; \
        $(DEL_FILE) -r $${TARGET}-$${VERSION}
 tarball.depends = changelog icon man