butcher butcher butcher
[gregoa/zavai.git] / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 %:
7         dh  $@
8
9 UPSTREAMVERSION=$(shell dpkg-parsechangelog | grep ^Version | cut -f2 -d' ' | cut -f1 -d-)
10
11 prepare_targz_from_git_checkout: clean
12        p=`pwd` ; \
13        pdir=`dirname $$p` ; \
14        pbase=`basename $$p` ; \
15        cd $$pdir ; \
16        GZIP=--best tar --exclude .git -czvf zavai_$(UPSTREAMVERSION).orig.tar.gz $$pbase
17