Some attempt to compile it with new vala, failed
authorEnrico Zini <enrico@enricozini.org>
Wed, 27 Apr 2011 21:39:41 +0000 (23:39 +0200)
committerEnrico Zini <enrico@enricozini.org>
Wed, 27 Apr 2011 21:39:41 +0000 (23:39 +0200)
debian/control
player/CMakeLists.txt
src/CMakeLists.txt

index 56890a0ba73681f4303d6f78fbf7b31711d7f8dd..e1f18ae063c3fb4afc386ef470d1088e2b487082 100644 (file)
@@ -2,7 +2,7 @@ Source: zavai
 Section: unknown
 Priority: extra
 Maintainer: Enrico Zini <enrico@enricozini.org>
-Build-Depends: debhelper (>= 7), cmake (>= 2.6), valac, libglib2.0-dev, libdbus-glib-1-dev, libgtk2.0-dev, libwnck-dev, libomhacks-dev (>= 0.5), liblua5.1-dev, libgps-dev
+Build-Depends: debhelper (>= 7), cmake (>= 2.6), valac, libglib2.0-dev, libdbus-glib-1-dev, libgtk2.0-dev, libwnck-dev, libomhacks-dev (>= 0.5), liblua5.1-dev, libgps-dev, libgstreamer-0.10-dev, libgee-dev
 Standards-Version: 3.8.4
 Homepage: http://git.debian.org/?p=users/enrico/zavai.git
 
index 735b1069691e8322339357540c9e986ddf7ce2a9..853da89f9870619aeb6168344ac27d0702660e27 100644 (file)
@@ -4,7 +4,7 @@ include(../vala.cmake)
 set(zavai_player_version 0.1)
 
 set(packages gtk+-2.0 gee-1.0)
-set(VALA_PACKAGES ${packages} gtkfisheyelist)
+set(VALA_PACKAGES ${packages} gtkfisheyelist x11)
 
 add_packages(ZP ${packages})
 
index e89883298fca434756391d8adea9c0a2529feb1e..882e2f331c203d3347fa68713e94c08f77c96459 100644 (file)
@@ -3,24 +3,24 @@ include(../vala.cmake)
 
 set(zavai_version 0.1)
 
-set(packages gtk+-2.0 dbus-glib-1>=0.80 libwnck-1.0>=2.26.0 lua5.1 libomhacks x11 gdk-x11-2.0 libgps gstreamer-0.10)
+set(packages gtk+-2.0 gdk-pixbuf-2.0 dbus-glib-1>=0.80 libwnck-1.0>=2.26.0 libomhacks x11 gdk-x11-2.0 libgps gstreamer-0.10)
 add_packages(ZAVAI ${packages})
 
-set(VALA_PACKAGES ${packages} posix linux-input dbus-extra gtkfisheyelist)
+set(VALA_PACKAGES x11 ${packages} posix linux-input dbus-extra gtkfisheyelist lua)
 set(VFLAGS --vapidir=${zavai_SOURCE_DIR} --vapidir=${gtkfisheyelist_BINARY_DIR})
 add_definitions(-Wall)
 # -Werror 
 
-pkg_check_modules(DKP devkit-power-gobject>=010)
-if (DKP_VERSION)
-  message("-- Using devkit-power-gobject version ${DKP_VERSION}")
-  set(VFLAGS ${VFLAGS} --define=USE_DKP)
-  set(VALA_PACKAGES ${VALA_PACKAGES} devkit-power-gobject)
-  add_definitions(-DUSE_DKP ${DKP_CFLAGS})
-  link_libraries(${DKP_LDFLAGS})
-else()
-  message("-- Not using devkit-power-gobject")
-endif ()
+#pkg_check_modules(DKP upower-glib>=0.9.9)
+#if (DKP_VERSION)
+#  message("-- Using upower-glib version ${DKP_VERSION}")
+#  set(VFLAGS ${VFLAGS} --define=USE_DKP)
+#  set(VALA_PACKAGES ${VALA_PACKAGES} upower-glib)
+#  add_definitions(-DUSE_DKP ${DKP_CFLAGS})
+#  link_libraries(${DKP_LDFLAGS})
+#else()
+#  message("-- Not using upower-glib")
+#endif ()
 
 add_definitions(-DWNCK_I_KNOW_THIS_IS_UNSTABLE -DI_KNOW_THE_DEVICEKIT_POWER_API_IS_SUBJECT_TO_CHANGE -I${gtkfisheyelist_BINARY_DIR} -I${zavai_BINARY_DIR})
 link_libraries(gtkfisheyelist-static)