Make wrmap.js compatible with jQuery v3.3.1 (no longer using deprecated context prope...
authorPhilipp Spitzer <philipp@spitzer.priv.at>
Fri, 17 May 2019 20:51:20 +0000 (20:51 +0000)
committerPhilipp Spitzer <philipp@spitzer.priv.at>
Fri, 17 May 2019 20:56:39 +0000 (22:56 +0200)
wrmap.js

index 8b7607b943123c0b98518a889fa846938ca27550..ab45a89f1e3d745f99a2ce9a0232ff872a3c8bb1 100644 (file)
--- a/wrmap.js
+++ b/wrmap.js
@@ -319,7 +319,7 @@ function init_wrmap(i, jq_map) {
        jq_map.width(width);
        jq_map.height(height);
        /*
        jq_map.width(width);
        jq_map.height(height);
        /*
-       var map = new OpenLayers.Map(jq_map.context, {
+       var map = new OpenLayers.Map(jq_map[0], {
                projection: EPSG3857,
                displayProjection: EPSG4326,
                units: "m",
                projection: EPSG3857,
                displayProjection: EPSG4326,
                units: "m",
@@ -337,7 +337,7 @@ function init_wrmap(i, jq_map) {
        });
 
        var map = new ol.Map({
        });
 
        var map = new ol.Map({
-               target: jq_map.context,
+               target: jq_map[0],
                layers: [
                        layer_map,
                        layer_sledrun
                layers: [
                        layer_map,
                        layer_sledrun